Pointer to fix for DownloadGDBlob errors (inSync 3)

Hey, I had a lightning strike and lost some hardware. I figured I’d try Insync 3.x as part of a entire rebuild of my desktop system. I’m doing a large restore and have run into Insync stalling on certain files with 12 “Unexpected error doing DownloadGDBlob:” errors piling up under “Attention required” and then all progress ceases.

So I eventually figured out that this was due to some old war web archives and some PUB files I have from an old 1990s era DTP program. Fairly obscure formats. I downloaded and zipped them, and Insync happily downloaded [note 1] the zipfiles. Then I ran into a maze of directories with hundreds. So I used rclone.

Ah, ha! rclone also failed, but it threw a useful error saying:

open file failed: Use the --drive-acknowledge-abuse flag to download this file: googleapi: Error 403: This file has been identified as malware or spam and cannot be downloaded., cannotDownloadAbusiveFile

I added the --drive-acknowledge-abuse to the rclone command line and everything downloaded just fine. It appears that Insync 3 does not handle this situation at all, and as errors accumulate, all syncing stops as the queue fills up with files it can not process.

I’m on Linux, but it should make no difference as this is a Google API error. I hope that this is of some use to the devteam. Best of luck, and thanks for a great product! I happily upgraded my account from Plus (or whatever I was) to Prime as part of the Insync 3 switchover. Keep the updates coming!

Note 1: I thought the zip archive trick fixed it, but it looks like it just re-queued the files. When they came up for download again, Google had peeked in the archive and declared it a bad file, causing the same problem. Tossing a password on the zips is a functional work-around. And I know the bad file flagging is erroneous, especially for the war files, as I wrote the program that generated those. :slight_smile:


Wow, thanks for this! Forwarded to our dev handling this issue :slight_smile:

1 Like

Guys this has to be fixed. I can’t sync my files because of this. I suspect it is exactly this. I have some 7z files and others that Google must be flagging, but 1.5 never had this problem.

I am dead in the water with this issue “Unexpected error doing DownloadGDBlob” on Windows 10b1903 when I upgraded to

It appears a fix exists for this issue, however, it has not been implemented. I am using version on Linux Mint after deciding to upgrade. Until this is fixed can you provide a download link for an older version?

You mean to our 1.x version? We have it here: Insync 1.5.7 builds

1 Like


I’m having the same issue on Ubuntu 19.04. Specifically, I receive the error “Unexpected error doing DownloadGDBlob: [filename]: Mismatched checksum,” as shown in the screenshot below. (I left out the filename.) I’m still on the free trial, so I’m seriously hoping that this can be resolved prior to the end of my trial period so that I can seriously consider purchasing a full license. If I can’t sync my files at all (which I can’t), then the software is not useful.



1 Like

I’m having the same issue on Ubuntu 18.04 and I’ve got version
It’s pretty annoying, and I hope that it will be fixed soon.

1 Like

I see that the problem only lies with my Google Photo’s folder.

Same error using 3.0.19 on openSUSE Tumbleweed.

Having this issue on Windows with

Any help would be greatly appreciated. Building new machine and don’t want to go back to old versions


I have the same problem on my machine with Linux Mint 19.3. Also, Insync seems to hang endlessly: syncing does not seem to work (I have files on the cloud that are not stored locally notwithstanding Insync has been running for days; my OneDrive local folder is still empty after 10 days). Perhaps the problems are related.

Same issues on Mac… Help!?

Wow! Over a month and this is still not fixed. What kind of a crap devteam is this? And Insync support seems to have gone on a silent retreat as well! What an absolute turd of a product!

Hello same problem here on Linux with version 3, license = Teams (in order to sync shared files),
please fix it or it is unsuable…

Hi everyone, the DownloadGDBlob errors are a bit scattered now, can you send in the screenshots of your errors to support@insynchq.com since the errors have specific messages after them.

Thank you.

This is shaking my faith in this product. Need to look elsewhere…

I’ve given Version a try. Likewise, still not syncing my files, causing massive problems. Interface locks up and starts flashing. Still not useable, brand new Windows 10 install…

Back to 1.5. Really need to fix this!!!

Any progress with that problem?

I’m also having constant errors since updating to 3 and very disappointed by the lack of support. I think I will go back to Ver 1

image !

I upgraded to and the errors went away for me.

And now it’s back…