Insync crashes on start (Ubuntu 16.04) (solved)


#1

Don’t know how long this has been going on, but I noticed that the icon was not present and the files, obviously, were not syncing.
Insync seems to crash at startup. This is the output of insync start --no-daemon :

ledoc@kuro:~$ insync start --no-daemon
Traceback (most recent call last):
  File "<string>", line 6, in <module>
  File "__main__.py", line 128, in <module>
  File "__main__insync__.py", line 170, in <module>
  File "__main__insync__.py", line 83, in main
  File "isyncd/linux/platform_impl.py", line 232, in use_this
  File "isyncd/linux/platform_impl.py", line 143, in __init__
  File "isyncd/linux/application_manager.py", line 25, in __init__
  File "isyncd/linux/application_manager.py", line 66, in __index_apps_for_mimetypes
  File "isyncd/linux/application_manager.py", line 140, in __record_desktop_files
  File "isyncd/linux/application_manager.py", line 117, in __canonicalize_mimetype
  File "xdg/Mime.py", line 57, in lookup
  File "xdg/Mime.py", line 64, in __init__
AssertionError
ledoc@kuro:~$

In synaptic, the insync package has version 2.0.0.40032-precise
Any thoughts?

ledoc@kuro:~$ cat /proc/version
Linux version 4.4.0-93-generic (buildd@lgw01-03) (gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.4) ) #116-Ubuntu SMP Fri Aug 11 21:17:51 UTC 2017

Thanks


#2

Hello? Any support person to tag someone about this?


#3

Sorry about the delay @Le_Doc tagging our engineer @jimperio and he will get back to you.


#4

I am experiencing a segfault in Ubuntu 16.04 too when Insync starts.

This is my ~/.config/Insync/out.txt

@jimperio I suspect Insync needs to be rebuilt against the correct gstreamer version, as I can see a lot of “undefined symbol” messages in the log.


#5

Somehow, 1.3.17.36167-trusty was installed, and I had the sources for trusty rather than for xenial in /etc/apt/sources.list.d/insync.list. Replacing trusty with xenial, and upgrading solved the problem here.


#6

This is the entry for Insync in my /etc/apt/sources.list file:

## Insync for syncing with Google Drive transparently
deb http://apt.insynchq.com/ubuntu xenial non-free contrib #Insync Google Drive syncing

Seems all in order.
@jimperio could we please have some sort of feedback? (@jaduenas it has been 13 days since I posted my problem initially and I provided lots of information.)


#7

@Le_Doc It appears that you’re using a beta version of Insync (2.0), which is currently unsupported. Did you install that version before, perhaps as part of its beta phase?

Could you for now try installing the version for 16.04 available in www.insynchq.com/downloads?


#8

@jimperio thanks for your answer. Reverting to version 1.3.17.36167-xenial was easy enough: just reinstalled it.
I remember I was part of the beta for v2.0, but it was working perfectly until recently. I don’t know exactly when, since Insync crashed silently and I hadn’t noticed the missing icon.
Anyway, thanks again. I am now happily synced. :slightly_smiling_face:


#9

Hi,
I’m using Insync 1.3.5.36069 version. When I have installed the Insync software in my Ubuntu 16.4 system it’s working fine but after few month Insync software instantly closed. I have reinstalled the New Version also but the same problem.


#10

Hi,

Can you run insync start --no-daemon and send your output here? Can you also let me know what specific installer you used? Thanks!