Insync disconnects wifi, unable to reconnect (with solution)

I’m on a nearly fresh Xubuntu install (info below), and I’m having the following issue. Insync starts fine, but at some point stops syncing (I can see this by watching the stream…instead of “last update 1s” it starts to say “last update 5 m”, and keeps getting longer, while there are still things to sync). When this happens, I have no internet access and my pings answer

Temporary failure in name resolution

Starting and restarting Insync does not seem to fix this (as in, I can’t get my internet back). If I disconnect from the wifi and try to reconnect, the system completely freezes, requiring a restart. I suppose the system freeze might not be “because of Insync”, but the source of the problem certainly is - I can happily use this system until I start Insync, at which point is always, after 5-10 min, disconnects the wifi.

Any help would be appreciated. I grabbed the logs right after this happened and will try to attach them here.

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.1 LTS
Release:	20.04
Codename:	focal
$ uname -a
Linux Xubunac 5.4.0-56-generic #62-Ubuntu SMP Mon Nov 23 19:20:19 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Logs, I hope!

I think I’ve solved this, by switching from the wl module to the b43 module. So although Insync seemed to be creating the problem, it was not the source of the problem.

1 Like

Hi @Christopher_Duston,

Glad to know you were able to sort it out. Can I help you with anything else?

Exact the same issue on my MacBook Pro and Ubuntu 21.04. Insync is killing my wifi connectiion after a few minutes and I have to reboot to get wlan again. I am on b43 module. No workaround is solving my problem. Please help!

Hi! Let me check this out with our engineers. Could you let me know if you are able to switch to another network and see if the same behavior persists?

Hi, it is my only home network. I tried my guest access of my network with the same result.

The issue happened when I tried to transfere 140 GB from my Google-drive to my freshly installed system.
I stopped Insync and am just copying the files manually. Perhaps 140 GB in one job is too much? But the software shouldn’t interfere with the wifi.

Insync is working fine in the same network on an old Acer notebook with Ubuntu 21.04 and also on the MacBook Pro with Mac OS X.

After all files will be transfered I will start Insync again and will let you know its behaviour.

Frank

PS: Probably my problem is solved: The opposite way of the above mentioned solution of Christopher in Dec 20: helped. I changed from b43 to the “wl-driver”.

Hi @fjoe,

Thank you for confirming that changing it from b43 to “wl-driver” helped. The 140GB may hit some hiccups due to the large sync job, but yes, it shouldn’t directly interfere with the wifi.

I’ll raise this to our engineers. :slight_smile:

UPDATE
From our engineers: Insync doesn’t interfere with the internet connection — this seems to be a driver issue (probably incompatible with the user’s hardware) causing the wifi to go down