InSync dnf update broken :: FEDORA 28: dnf update to v1.5.7.37371-fc26 fails



The following is happening on all of my computers:

user@fedora28$ sudo dnf -y update insync

Last metadata expiration check: 0:13:29 ago on Tue 02 Apr 2019 06:22:55 PM EDT.
Dependencies resolved.
 Package                Arch                   Version                             Repository              Size
 insync                 x86_64                           insync                 135 M

Transaction Summary
Upgrade  1 Package

Total download size: 135 M
Downloading Packages:
insync-                                               42 MB/s | 135 MB     00:03    
Total                                                                            42 MB/s | 135 MB     00:03     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                        1/1 
  Upgrading        : insync-                                                         1/2 
Error unpacking rpm package insync-
Error unpacking rpm package insync-
error: unpacking of archive failed on file /usr/bin/insync: cpio: rename failed - Operation not permitted
insync- was supposed to be installed but is not!
  Verifying        : insync-                                                         1/2 
insync- was supposed to be removed but is not!
  Verifying        : insync-                                                         2/2 


Error: Transaction failed



Hi @NYCeyes,

Can you let me know what happens if you run sudo yum upgrade? Does the issue persist?



Yes, it persists. I just tried it.

Also, if you remove inSync and try to install the rpm manually, it fails with the same error.

So it’s not a yum / dnf issue. I think it’s a script in the RPM not accounting for something.

Thank you!


Can you fix this asap please?


Are you guys still in business? Are you going out of business? Where is this overdue fix? No replies? Do you think this is good customer service?