Insync-headless 1.x - Can't authenticate with Google


I’ve been using insync-headless 1.x on my home server with Google Drive for a few years without issue. I noticed a few weeks ago however that files were no longer being synced. I tried various troubleshooting steps without luck.

In the end I decided to remove the account and start fresh (as advised on this forum). However now I can’t seem to authorise Insync with Google. Here are the steps I followed:

Error: (401, '{\n  "error": "unauthorized_client",\n  "error_description": "Unauthorized"\n}')

Sometimes I get the following (usually this error appears if I try to run it a second time)

Error: (400, '{\n  "error": "invalid_grant",\n  "error_description": "Bad Request"\n}')

I noticed that Insync is no longer appearing in after I generate a new auth code. Could this be the issue? Any way to resolve this? I tried adding it several times.

Or has something changed in insync-headless 1.x?

Many thanks.

Adding some more info if it helps:

  • OS: Debian 12 Bookworm
  • insync-headless: v1.5.7.37371

Hello @eskay993!

My apologies for the issues you’re facing. After further checking, this is due the oauth flow deprecation in the Google API. This means that users must update their Insync version to 3.x, and therefore acquire the compatible license to continue using Headless.

I see that you’ve also emailed us regarding this and have responded there as well. Thank you!

For reference, here is the official documentation from Google stating the changes in their oauth flows:

Hi Mia

Thank you for the reply and for the info on Google’s blog. That’s a shame that 1.x no longer works. I will look into the other options as you suggested.

Many thanks.

1 Like

In my case I am gettiing the same auth message but I cannot updgrade to 3 because you don’t have an ARM version for headless version, I would like to preserve my 1.x licence in the meantime while you are considering supporting ARM. It would be helpful iif you can help me to find a solution or alternative.

1 Like