Insync-headless crashing on Ubuntu 19.10

From time to time, my insync-headless installation is crashing.

On running get_status, I get the following output:
insync-headless get_status
Traceback (most recent call last):
File “isyncd/linux/headless/cli.py”, line 108, in ipc_insync
File “socket.py”, line 228, in meth
error: [Errno 111] Connection refused

insync version 1.5.7.37371-artful
I do not have the new insync repo added, because although gnome etc. installed, I run my server headless, and I want insync running as a background task, with interaction on the command line. (based on this advice: Linux Headless reinstall - how to do safely?)

Hi @Dom
Can you send us the output of insync-headless start --no-daemon?

1 Like

Sure. Here is the redacted output. It launches just fine, and only dies after an indetermine amount of time.

insync-headless start --no-daemon
Qt WebEngine seems to be initialized from a plugin. Please set Qt::AA_ShareOpenGLContexts using QCoreApplication::setAttribute before constructing QGuiApplication.
INFO     2019-11-27 20:47:52,175 [__main__insync__:main:105] insync version: 1.5.7.37371
INFO     2019-11-27 20:47:52,176 [__main__insync__:main:106] client created <ideskmain.client.Client object at 0x7f9812229f50>
INFO     2019-11-27 20:47:52,178 [unix_socket_server_portable:start:49] unix socket server thread start
INFO     2019-11-27 20:47:52,178 [__main__insync__:main:114] starting client
INFO     2019-11-27 20:47:52,183 [fswatch:_start:532] LinuxFSWatcher._start
INFO     2019-11-27 20:47:52,184 [fswatch:_pull_loop:267] Inotify loop enter
INFO     2019-11-27 20:47:52,202 [gdsyncer:sync_account:153] Syncing GDUser(..REDACTED..).
INFO     2019-11-27 20:48:15,428 [fswatch:watch:550] watch origin: /home/..REDACTED..
INFO     2019-11-27 20:48:26,734 [fswatch:watch:550] watch origin: /home/..REDACTED2..
INFO     2019-11-27 20:48:28,162 [fswatch:watch:550] watch origin: /home/..REDACTED3..
WARNING  2019-11-27 20:48:29,980 [fswatch:watch_tree:136] Symlink target already watched, skipping: u'/home/..REDACTED4..'
[about 10-20 similar lines, all pointing to individual files]
INFO     2019-11-27 20:48:30,011 [fswatch:watch:550] watch origin: /home/..REDACTED5..
WARNING  2019-11-27 20:48:31,248 [fswatch:add_watch:181] Inotify failed to watch: /home/..REDACTED6..
INFO     2019-11-27 20:48:31,316 [client:__on_gd_account_added:891] GDUser(..REDACTED..) (existing) is now being synced.
INFO     2019-11-27 20:49:13,317 [_updater:_run:129] No updater available.  

insync has run fine for years, but this is a new system, with various changes:

  • it has the desktop installed (rather than being ubuntu server), although it is still run headless.
  • It is a new install (more recent OS, and new hardware, same file system, same config files and DBs)

I’m surprised to see the reference to Qt GUI components, as I’m explicitly running insync-headless. As I’ve said before, I run my server with no monitor or keyboard - but I do have regular ubuntu desktop installed. If there are interactions between insync-headless and the ubuntu desktop, then that would be one change that might affect things.

@Dom
You might have installed the GUI version of Insync insync package instead of the headless only insync-headless package since there are logs about Qt.

Can you send us your logs since the output above doesn’t show errors on why Insync crashes?

I’ve got a suspicion that switching to headless might be the solution… I’ve been trying to get VNC working, and that has included killing VNC sessions (and probably the desktop session at the same time). Which would probably kill insync…

What repo should I use for insync-headless?

I have this same error when trying to start insync 1.5.7-3 from the archlinux AUR repo.

@Dom
You can use apt.insynchq.com but use bionic instead of disco
deb http://apt.insynchq.com/ubuntu bionic non-free contrib

Hi @shinemacs
Can you send us the output of insync start --no-daemon ?
You could also try out our Insync 3.0 build from the AUR repo

insync start --no-daemon
which: no kreadconfig in (/usr/lib/insync:/home/[mynamewithheld]/.bin:/opt/google-cloud-sdk/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
INFO     2019-12-02 12:53:52,534 [__main__insync__:main:105] insync version: 1.5.7.37371
INFO     2019-12-02 12:53:52,535 [__main__insync__:main:106] client created <ideskmain.client.Client object at 0x7f2d080e0c50>
INFO     2019-12-02 12:53:52,536 [unix_socket_server_portable:start:49] unix socket server thread start
INFO     2019-12-02 12:53:52,536 [__main__insync__:main:114] starting client
INFO     2019-12-02 12:53:52,542 [fswatch:_start:532] LinuxFSWatcher._start
INFO     2019-12-02 12:53:52,543 [fswatch:_pull_loop:267] Inotify loop enter
libpng warning: iCCP: known incorrect sRGB profile
Received signal 11 SEGV_MAPERR 000000000100
#0 0x7f2cfed9e58f <unknown>
#1 0x7f2cfd7d085d <unknown>
#2 0x7f2cfed9ea9e <unknown>
#3 0x7f2dba58f930 <unknown>
#4 0x7f2dad8b2604 <unknown>
#5 0x7f2dad8b3898 <unknown>
#6 0x7f2db8343a45 glXCreatePbuffer
#7 0x7f2cfd8327b9 <unknown>
#8 0x7f2cfd81d818 <unknown>
#9 0x7f2cff8da47d <unknown>
#10 0x7f2cfdb21151 <unknown>
#11 0x7f2cfdb22945 <unknown>
#12 0x7f2cffd90707 <unknown>
#13 0x7f2d015c7375 <unknown>
#14 0x7f2cfee06f45 <unknown>
#15 0x7f2cfee022e0 <unknown>
#16 0x7f2dba5844cf start_thread
#17 0x7f2dba3492d3 __GI___clone
  r8: 0000000000000000  r9: 0000000000000001 r10: 0000000000000000 r11: 0000000000000206
 r12: 00005613e982f090 r13: 00005613e9871060 r14: 0000000000000001 r15: 0000000000000009
  di: 00005613e982f090  si: 0000000000000000  bp: 00005613e982f090  bx: 0000000000000000
  dx: 0000000000008041  ax: ffffffffffffff50  cx: 0000000000000000  sp: 00007f2ca17f9480
  ip: 00007f2dad8b2604 efl: 0000000000010202 cgf: 002b000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000100
[end of stack trace]
Calling _exit(1). Core file will not be generated.

Kurt - I’ve already tried version 3 from the AUR. It’s a total mess, as I have repeatedly said on this forum.