Insync not removing folders shared in My Drive

I had a folder in Shared with me that I added to My Drive - it syncs to the local disk. I’ve now removed it from my drive however, it still exists on the local disk - it should have been removed.

It’s not selected in the “Shared with me” folders to sync, it’s not visible in the My Drive list on Insync.

If I create a file in the local folder, it gets replicated to the shared folder on the Google Copy so, if I delete these files, I’ll delete all of the cloud files.

How should I proceed?


I second this. Not sure if its a bug or a feature request. But I need this behaviour as well.

I worked around by checking the folder in Shared With Me in Insync - it nothing - then unchecking it where it removed it after a warning prompt.

I verified that the GD sync app behaves as expected.

@Michael_Thwaite @Dan_Rempel How did you remove the shared folder from “My Drive”? We will attempt to replicate this issue and improve Insync’s behavior regarding such files.

Thanks for taking this on.

  1. Have a friend share out a folder to you
  2. Add this to My-Drive
  3. Install and activate Insync (files sync to local)
  4. Return to the web UI and "Remove’ the folder in my drive - this should ripple down to the local copy.

Perhaps there’s a new status update message you’re responding to? Just guessing though as I have no idea how the Drive API works!


@Michael_Thwaite Ah, alright, thank you for the more detailed information. I think I’ve been able to replicate it. In my case, it did initially get removed from the Insync folder, but when the file was edited, it synced back down. I’ll add this issue to our list and will keep this thread updated of any progress.

Great, thanks for that.


After sync is complete, I select insync > manage > selective sync and deselect a folder.

I would expect that insync would:

  1. Ensure it exists on the cloud
  2. Remove it locally
  3. No longer sync that file/directory

What it appears to do:

  1. No longer sync that file/directory

So I end up with an orphan directory of files in my insync folder.

1 Like

Sorry for the necro, but this is exactly the issue I have now (6 ears later), and other more threads are slightly different (they have error messages, while on my insync, no error is shown). Plus, it never got reply from the dev team.

I also noticed that new files are taken into account, and fear that removing the folder locally myself will delete it from Drive, even though they are shared with another account I also have control of.

In my case, the parent directory is shared, so the directory is only shared indirectly; I fear that removing the folder will register a sub-folder removal on the parent directory. While removing a root shared directory wouldn’t worry me, as such shared directories are generally kept on other accounts.

By the way, I use insync on both accounts simultaneously, if this matters. It means I have 2 copies of the shared root folder, with a different set of sub-folders synced on each side. However, some of the folders are present on both sides, yet only one insync account recognizes the Sync, the other is a ghost sync.

I tried to re-sync, then re-unsync, but the folder is still there on the unsynced side.

I guess I’m gonna pick a test directory and try a few things like disabling share or removing a folder after adding a copy with a different name, but it will still just be a workaround…

And… wrong alert. I was unsyncing the folder on the wrong account, I didn’t pay enough attention to the order of my two account icons in the insync window. Removing the folder on the correct account worked as expected.

So my necro was wrong, sorry for all the people I notified.

No worries @huulong and thank you for following it up with this update. :slight_smile: Let me know if you need anything else!