Insync not responding (beachball over the menu icon)

The last few days/week insync seeems to have crashed/hung when my computer wakes up. If I hover over the menu icon I get a spinning beach ball. I just updated the 1.3.17 version last night but this morning it’s doing the same thing. A quick look at activity monitors stats reveals millions of faults and a recent hang every few seconds.

There do not seem to be messages written to any of the system logs. I can quit and restart the application, and it works for a while, but then crashes at some point when the computer goes to sleep.


1 Like

Thanks for reporting @Icarus. Please send your log files to in case our engineer needs this for investigation cc @jimperio

No Problem. I just sent them. Thanks.

Same problem here since insync updated itself to 1.3.17.

Any update on this? My employees and I have all experienced this at various times.

Mac OS: 10.12.5

My Insync client issues have not reappeared (for no particular reason that I can find) for a week or so. If you are willing you might send them your log files as described in the link above. I know fixing erratic bugs is always a challenge, so the more data they have the better their chances.

I’ve also been experiencing this issue for a few weeks now. Running Insync 1.3.17 on Mac OS 10.12.5. After waking the computer, Insync stops responding (and syncing) until I do a complete restart. Any update on a fix?

Hello. I also experience the same issue.
I have to manually kill and restart Insync. After a random period of time, it will get stucked.
I wish an update will fix it too.

We are still currently investigating this issue. For now you can try the following:

To restart Insync, open Activity Monitor, search for Insync, and quit it from there before relaunching it.

  1. Check if the Insync Finder Sync extension is enabled, and if so, disable it and restart Insync. (System Preferences -> Extensions)

  2. Open and search for any Insync-related messages in “All messages” and also under “system.log” and send those to us via

In the meantime, please try downgrading to 1.3.16 and check if it still freezes: (this build does not auto update to 1.3.17)

Hello. I also experience the same issue.

I just wanted to add that downgrading to 1.3.16 mentioned in jaduenas post has solved it for me. I haven’t had this issue for more than a couple weeks now. Thanks.

1 Like

Hi your link have been updated to

Does that still help coz I am facing the same issue.

1 Like

Same problem for me here as well… Also noticed (like Nicholas_Yong) that the current fix link to download 1.3.16 is now so same question as him… does that fix the issue??

@Nicholas_Yong @Jeremy_Moss sorry for the confusion guys – is actually a modified version of 1.3.16 (we can’t give you 1.3.16.dmg because it’ll just auto-update to the latest version that has issues)

We’ve heard back from users that it has fixed the issue for them. Please try it out and let us know :thumbsup:

1 Like

Well, I don’t know if it solves the problems of crashing yet but it certainly brought back the bug where it opens everything in the wrong browser that was fixed before… My default browser is set to Chrome and it now, once again, opens everything up in Firefox… Guess I get one bug or the other for now :wink:

I have this same issue. I’m currently testing the modified version as stipulated above and I’ll report back if I continue to experience the issue.

I’m experiencing this issue still as well currently using version

We’re still working on this issue (we have leads but haven’t consistently replicated the issue yet). Have you tried upgrading to macOS 10.12.6 to see if it solves your issue?


Downgrading to 1.3.16 ( seems to have fixed the hanging issue, but has introduced an issue where files deleted on one machine are not being removed from another. GDrive reflects the deletion, as do other apps that sync with GDrive, so it’s isolated to InSync.

My biggest concern at this point is exposure to data loss because of unstable InSync coding. Please let me know if there’s an even more stable option, even if some features are lost in the downgrade.

macOS: 10.12.6

EDIT: I should note that the status indicators (errors, progress, green checks, etc.) are all ok on the machine having the issue.

1 Like


:white_check_mark: issue seems to be resolved by updating to the latest macOS 10.12.6
:white_check_mark: Make sure you’re on Insync 1.3.17 (to check: Insync > click + > click Support)

Installer available here if you need it.

Please help us test. Post feedback here or email :thumbsup: