Insync not starting

Hello. I am using Ubuntu 15.04
Insync can’t start.
I get this message when I try to run Insync by terminal:

Traceback (most recent call last):
File “”, line 5, in
zipimport.ZipImportError: not a Zip file: ‘/usr/lib/insync/’

The only solution I find is re install every time the program…
Everyone know a solution?

@Cirelli Please try this: Insync 1.2.10 miss configuration settings after a computer reboot

I add -b /usr/lib/insync/ to /etc/prelink.conf to resolve this, it works fine!

Thank you!

I tried the solution suggested by Cirelli but it doesn’t seem to work for me. Any other ideas?

@Donnie: What Linux distribution and version are you using? Do you have prelink installed?

1 Like

I’m using ubuntu 14.04 and prelink is installed

@Donnie: Please try running sudo prelink -u /usr/lib/insync/ to undo the prelink. If that didn’t work try reinstalling Insync.

After reinstallation insync is working properly.
I guess that adding the exception to prelink is not sufficient and you should also reinstall insync to make things work.
Thank you for your help!

@lpugoy: I can’t seem to uninstall insync after this issue (nor re-install).
I tried:

  1. Downloading the new pacakge
  2. sudo dpkg --remove --force-remove-reinstreq insync
  3. sudo apt-get --reinstall install insync
  4. sudo apt-get install insync
  5. sudo apt-get --reinstall install insync

I keep getting the same ZipError for all of the above.
Can you provide a script that will purge all of insync so that I can re-install it properly?

@Jason_Ramapuram: Are you using prelink? If so have you tried running sudo prelink -u /usr/lib/insync/ to undo the prelink? You might also need to add -b /usr/lib/insync/ to /etc/prelink.conf.

@lpugoy: Yes I have that fix already in place. I cannot reinstall or uninstall though. A script to uninstall would be useful in this case.

@Jason_Ramapuram: Why can’t you uninstall? What are the outputs of the commands you ran above?

@lpugoy: I get the same error mentioned above :

dpkg: error processing package insync (–remove):
subprocess installed pre-removal script returned error exit status 1
Traceback (…)
zipimport.ZipImportError: not a Zip file: '/usr/lib/insync/

I have done the required steps to setup prelink and have even disabled it, but this issue persists.

@Jason_Ramapuram: I see. Please run the following commands to debug Insync’s prerm script.

sudo su -
tail -n +5 /var/lib/dpkg/info/insync.prerm | head -n -6 | grep -v dev_null > "$script"
/usr/lib/insync/py "$script"

@lpugoy : So while trying some things I accidently deleted :S So the command you listed fails as follows:

warp ~ # cd
warp ~ # script=$(mktemp)
warp ~ # tail -n +5 /var/lib/dpkg/info/insync.prerm | head -n -6 | grep -v dev_null > "$script"
warp ~ # /usr/lib/insync/py "$script"
Traceback (most recent call last):
 File "<string>", line 5, in <module>
zipimport.ZipImportError: not a Zip file

@Jason_Ramapuram: I see. Please try deleting or moving the file /var/lib/dpkg/info/insync.prerm then retry uninstalling Insync. I think that should work now that the prerm script is not raising an error.

@lpugoy: That did it! Thanks!

This worked for me too! I’m on RHEL 8 FWIW