Insync not syncing, acting weird (KeePass directory)

I was having trouble that changes made on Linux to my insync database weren’t getting uploaded to drive. Doing some more experiments, I tried backing the files up to somewhere else, then removing them, expecting they should then be removed from Drive… but instead, 3 seconds after I’ve removed the files, they all reappear again… insync has downloaded them from drive. It will never delete them, never upload them.

I notice my Linux insync is 3.5.1 instead of 3.5.2 like windows. But then there are no updates available on which gives a permission denied error. So has insync broken their ubuntu updates?

Hi @xpusostomos,

Nothing is broken, it seems like the Linux team has not updated the APT repository yet (there are no auto-updates pushed on Linux). Let me bring it up with them.

Can you let me know if you’re doing a one-way sync, as indicated by either an upward or downward arrow on the folder icon on the Insync app?

Should I expect to see “permission denied” to merely access ? It’s one thing to not have a version update… but it’s another if the whole site is inaccessible.

The CSS and LSS icons have the circular 2-way sync icon, if that’s what you’re asking.

Can you send the complete output of the error to so I can double-check? I may have been mistaken about nothing being broken since you first-handedly experienced it.

Please also send me a screenshot of the CSS and LSS icons you described and do specify which folder/s weren’t getting uploaded to drive.

Complete output of what error? Accessing your Linux update site? But you can click the link above yourself to see the error.

I’ve attached the screenshot of the CSS and LSS icons. The folder that I noticed wasn’t getting uploaded was Google/AppData/KeePass … though I don’t see how that can help you.

Screenshot from 2021-09-02 17-06-25

Hi @xpusostomos

If the repo has been added to your apt sources list (Refer to , Repositories tab -> Apt) run the following commands:
sudo apt update
sudo apt install insync

1 Like

As for the KeePass - let me send this to our team as there have been a couple of users who have raised sync issues with this directory. Could you let me know if this has always been the case for that KeePass folder or is this a new issue?

I don’t remember adding something to KeePass from my Linux machine before. So while I can say it synced fine coming down. I can’t say for sure if I’ve ever synced up before from this machine or from Linux.

I see. I’m awaiting our engineer’s advise on this and will update you accordingly :slight_smile: Thank you for your patience!

Hi @xpusostomos :slight_smile: We’ll need to check out your logs.db – could you email that to with the link to this post please?

Should I wait a year, and then submit logs? Because the logs I submitted a year ago for a different problem are ignored. The bug from that issue is still there, even though you know exactly where it is, why it is, you’ve got every conceivable log, and yet you can’t be bothered fixing it. After a year my insync icon in my tray still shows an error from trying to write to a read-only synced drive. Why should I exert all this effort for nothing?

Hi @xpusostomos. I understand your frustrations regarding this matter and having to send your log files again. The logs may reveal new information related to the KeePass directory itself, and would help us navigate the issue with better direction.

As for the read-only issue you reported back then, per my comment here, we are lining up an improvement to handle these errors better.

I did a full reinstall of my Linux operating system, installed insync… and it’s still not working. Only syncs in one direction. As I pointed out in my email to you, I have a teams license so one way sync isn’t even an option.