Insync not working with Ubuntu Jammy (FIXED)

Will have this checked out @elzxr!

1 Like

I’ve got the same problem, do we have an update on the timeline for a fix?

1 Like

I can confirm the issue as well on a group of test machines, please advise.

I confirm the issue on Kubuntu 22.04 (beta).

1 Like

Thank you for reporting this and my apologies for the trouble!

Our Linux team has lined this up as a priority so that we can catch up with the official release. I will be updating this thread once the build is out. We appreciate your patience!

Same error - KUbuntu 22.04 + Dell XPS 9510
The workaround is to remove

sudo mv /usr/lib/insync/./ /usr/lib/insync/./

Insync starts and seems to be working fine. @mia - I hope this helps


Thank you for sharing the workaround, @Andrei_Karneyenka! This is very much appreciated.

I have also forwarded this to our engineer for reference.

Confirming that this workaround works for me too

1 Like

After installation, it is not possible to choose the destination folder for the files, the software closes “bug”. It is still not possible to use it on Ubuntu 22.04, even with removing the lib

How do I get the beta version for Jammy. Will test it also, and see if I have same issue.


@Andrei_Karneyenka this issue has plagued me for weeks, and your workaround worked perfectly. Thank you!

1 Like

@Andrei_Karneyenka @mia
I can also confirm this workaround allows the app to run on a few LG Gram test systems. Thank you.

1 Like

This same issue (and the workaround) applies to Fedora 36. It would be good if your Linux team was a little bit more proactive about this sort of thing. Generally both Fedora and Ubuntu put out releases in April and October. Betas typically go out a month in advance. Your Linux team should start testing as soon as the beta comes out.


Hi @reiscw,

Thank you for the feedback, I will send this to our Linux Team so we can line up improvements in our processes regarding updates and beta releases. :slight_smile:

Just piling on here in support for Ubuntu 22 support.

Perhaps when Ubuntu opens their betas, Insync could open the apt repos for that version, with the idea that its in beta and might not be stable yet. I think most users would be happy to try it out.


Thank you for the feedback and suggestion, @apockill :slight_smile: I will bring this up with our Linux Team.

Is there an ETA as to when my Insync will work on Ubuntu 22.04?

Hello, we are working on releasing the official build in an upcoming version release.

In the meantime, we suggest to use the workaround provided above. Thank you!

Also, I’m not sure if anyone else has this issue with trying to share from Nautilus, but when I use the “Share” option it causes the app to shut down (“View on the web” works fine).

In my case, the workaround works, but only if I am in a “ubuntu on xorg” session; i.e. not in Wayland. I am running 22.04 on a 2019 iMac, so the problem might be unique to Macs. However, I noted another post where the Insync icon wasn’t appearing in Wayland, but was OK in xorg. when running Plasma. Maybe the two are related?