Insync not working with Ubuntu Jammy (FIXED)

For me insync is also not working on Ubuntu 22.04 LTS. If I start insync with

insync start --no-daemon

I get the following error:

Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile) 
Fatal Python error: Aborted

Thread 0x00007f940b7fe640 (most recent call first):
  File "concurrent/futures/", line 78 in _worker
  File "", line 870 in run
  File "", line 926 in _bootstrap_inner
  File "", line 890 in _bootstrap

Thread 0x00007f940bfff640 (most recent call first):
  File "concurrent/futures/", line 78 in _worker

When there is an update of insync available?

I wasn’t the originator of this workaround. But, it does work.

I dont understand why there is no insync version compatible with a ubuntu LTS release, 8 days after oficial release. The ubuntu release cycle is well documented with a rasonable ammount of time before final release.

Moving a standard c++ standard library is not a solution, i need them for my work.

What is the planned release date of the version of insync without this bug?

tank you!


I have the same issue on official Kubuntu 22.04 LTS.

libGL error: MESA-LOADER: failed to open iris: /usr/lib/dri/ cannot open shared object file: No such file or directory (search paths /usr/lib/x86_64-linux-gnu/dri:$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
libGL error: failed to load driver: iris

Hello everyone, we from the engineering team apologize for the delay, and are working on getting the updated builds out and tested ASAP - within the week.

Hello everyone,

Apologies for the delay, here are the builds for:
Ubuntu 22.04 -
Fedora 36 -

Let us know if there are issues with these builds

Thank you!


Hi everyone, the builds are also available via repositories and our downloads page. Thank you all!


It is now working on my Ubuntu 22.04 Thanks!

It is working on my ubuntu 22.04 system too. The ppa is now available for jammy as well. Thanks for the good work.

I join in thanking you for the good work and the quick solution. Insync is working great on my Ubuntu 22.04.

On behalf of the Insync Team, I would like to thank all of you for your wonderful support and trust in us!

This version is also working on Pop OS 22.04
There is just one slight bug, if you install insync via .deb file.
It will create /etc/apt/sources.list.d/insync.list file where is deb xenial non-free contrib source info.

So whenever you will update packages, it will downgrade insync to xenial (Ubuntu 16.04). SImple fix, just change xenial to jammy in that file and it works perfectly afterwards. Just pointing it out for devs, they might want to look at that.

And like everyone said, thank you for the quick fix of wayland compatibility, it works like a charm!

1 Like

Hey guys… the procedure for install insync is wrong and need to be update… I can’t add repository, because ubuntu complains about key stuffs. apt-key is deprecated. Also I can’t install insync on fresh install of ubuntu 22.04 LTS. could you help me please?

Have you tried installing it from the .deb package? Just download it, use sudo dpkg -i *~/Downloads/name_of_the_file.deb* in terminal and don’t forget to change the source info from xenial to jammy as I described in the comment above yours. Then it works perfectly.

1 Like

Just had to move again or Insync app window keeps crashing when trying to open it.

OS: Ubuntu 22.04 with all the latest updates
Insync version: v3.7.6.50356

I saw a message indicating that this was fixed with 3.7.5… was that re-introduced with 3.7.6?

Hey @wolfi!

Let me check that out with our engineers!

Thank you @mia!

Not 100% sure if it affects all users. Worked fine an hour later when I tried exactly the same on another laptop that had the exact same software versions. There it was not necessary to remove the library file. Not sure what made the difference.

1 Like

@wolfi Am I understanding that both Ubuntu 22.04 machines 1 and 2 had the same setup wherein you had to do the workaround so Insync runs on them? And on machine 1 you had to delete the file, but on machine 2 you just updated your Insync packages and it ran as expected?

@miamoran Correct. I just re-checked on three machines. On my Desktop and one laptop all is fine. Did not have to manually change anything. Only another laptop is affected. There I had to rename the lib file.

Insync was starting (and I guess syncing fine) on all three machines. Could see the tray icon on all. Only issue was when clicking on the tray icon to open the app the app immediately crashed on the affected laptop.

The affected laptop is a laptop. Has quite new hardware and most significant difference from a user perspective might be the display with fractal scaling enabled in the operating system. But really not sure how that would play a role. And it really works well after the workaround. Not complaining… more an FYI

Edit: Just went back an tested my theory but that was not it. Having scaling enabled / disabled on an operating system level does not make a difference. I use 200% (no fractional scaling) by default, but also same issue persists at 100%. Really have no idea what the difference is to the other machines. Same OS und updates on all of them.

Gotcha @wolfi! Will send details as soon as I know more from our Linux team. Thanks for the continuous efforts to report these issues to us, we appreciate you!