Insync not working with Ubuntu Jammy (FIXED)

I wasn’t the originator of this workaround. But, it does work.

I dont understand why there is no insync version compatible with a ubuntu LTS release, 8 days after oficial release. The ubuntu release cycle is well documented with a rasonable ammount of time before final release.

Moving a standard c++ standard library is not a solution, i need them for my work.

What is the planned release date of the version of insync without this bug?

tank you!

5 Likes

I have the same issue on official Kubuntu 22.04 LTS.

libGL error: MESA-LOADER: failed to open iris: /usr/lib/dri/iris_dri.so: cannot open shared object file: No such file or directory (search paths /usr/lib/x86_64-linux-gnu/dri:$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
libGL error: failed to load driver: iris

Hello everyone, we from the engineering team apologize for the delay, and are working on getting the updated builds out and tested ASAP - within the week.

Hello everyone,

Apologies for the delay, here are the builds for:
Ubuntu 22.04 - https://d2t3ff60b2tol4.cloudfront.net/builds/insync_3.7.5.50350-jammy_amd64.deb
Fedora 36 - https://d2t3ff60b2tol4.cloudfront.net/builds/insync-3.7.5.50350-fc36.x86_64.rpm

Let us know if there are issues with these builds

Thank you!

5 Likes

Hi everyone, the builds are also available via repositories and our downloads page. Thank you all!

3 Likes

It is now working on my Ubuntu 22.04 Thanks!

It is working on my ubuntu 22.04 system too. The ppa is now available for jammy as well. Thanks for the good work.

I join in thanking you for the good work and the quick solution. Insync is working great on my Ubuntu 22.04.

On behalf of the Insync Team, I would like to thank all of you for your wonderful support and trust in us!

This version is also working on Pop OS 22.04
There is just one slight bug, if you install insync via .deb file.
It will create /etc/apt/sources.list.d/insync.list file where is deb http://apt.insync.io/ubuntu xenial non-free contrib source info.

So whenever you will update packages, it will downgrade insync to xenial (Ubuntu 16.04). SImple fix, just change xenial to jammy in that file and it works perfectly afterwards. Just pointing it out for devs, they might want to look at that.

And like everyone said, thank you for the quick fix of wayland compatibility, it works like a charm!

1 Like

Hey guys… the procedure for install insync is wrong and need to be update… I can’t add repository, because ubuntu complains about key stuffs. apt-key is deprecated. Also I can’t install insync on fresh install of ubuntu 22.04 LTS. could you help me please?

Have you tried installing it from the .deb package? Just download it, use sudo dpkg -i *~/Downloads/name_of_the_file.deb* in terminal and don’t forget to change the source info from xenial to jammy as I described in the comment above yours. Then it works perfectly.

1 Like

Just had to move libstdc++.so.6 again or Insync app window keeps crashing when trying to open it.

OS: Ubuntu 22.04 with all the latest updates
Insync version: v3.7.6.50356

I saw a message indicating that this was fixed with 3.7.5… was that re-introduced with 3.7.6?

Hey @wolfi!

Let me check that out with our engineers!

Thank you @mia!

Not 100% sure if it affects all users. Worked fine an hour later when I tried exactly the same on another laptop that had the exact same software versions. There it was not necessary to remove the library file. Not sure what made the difference.

1 Like

@wolfi Am I understanding that both Ubuntu 22.04 machines 1 and 2 had the same setup wherein you had to do the workaround so Insync runs on them? And on machine 1 you had to delete the file, but on machine 2 you just updated your Insync packages and it ran as expected?

@miamoran Correct. I just re-checked on three machines. On my Desktop and one laptop all is fine. Did not have to manually change anything. Only another laptop is affected. There I had to rename the lib file.

Insync was starting (and I guess syncing fine) on all three machines. Could see the tray icon on all. Only issue was when clicking on the tray icon to open the app the app immediately crashed on the affected laptop.

The affected laptop is a frame.work laptop. Has quite new hardware and most significant difference from a user perspective might be the display with fractal scaling enabled in the operating system. But really not sure how that would play a role. And it really works well after the workaround. Not complaining… more an FYI

Edit: Just went back an tested my theory but that was not it. Having scaling enabled / disabled on an operating system level does not make a difference. I use 200% (no fractional scaling) by default, but also same issue persists at 100%. Really have no idea what the difference is to the other machines. Same OS und updates on all of them.

Gotcha @wolfi! Will send details as soon as I know more from our Linux team. Thanks for the continuous efforts to report these issues to us, we appreciate you!

Hello everybody,

I had the same problem everybody show in the first messages.

Today, post purgate al Insync package and personal folder (apt purge insync and remove ~/.config/Insync), I had upgrade the apt repo file (/etc/apt/sources.list.d/insync.list) to deb [signed-by=/usr/share/keyrings/insync-keyring.gpg] http://apt.insync.io/ubuntu jammy non-free contrib with /usr/share/keyrings/insync-keyring.gpg where I had put the gpg, and I re install with apt install insync and almost everything work fine.

When I had try login in insync with Google account, I had a Google error page. I went back to de insync app, and I try (in the rigth up corner) the alternative login way (copy a URL, enter to this page, allow insync in Google, and copy/paste de Google response token to Insync app), and everything work fine again.

Could be a good idea that Insync software engineers fix login with Google account too.

Looking for something usefull in my logs about the error in Google login, I only find this (in .config/Insync/out.txt):

INFO     2022-06-01 20:09:25,822 [app:start_core:53] core started
INFO     2022-06-01 20:09:25,823 [unix_socket_server:start:93] unix socket server thread start
Opening in existing browser session.
Opening in existing browser session.
js: ResizeObserver loop limit exceeded
INFO     2022-06-01 20:10:42,105 [licensework:_do:89] License received: License{'subscriptions': [BaseLicense.Subscription{'code': 'prime', 'is_recurring': False, 'name': 'Prime', 'capabilities': ['ignore_rules', 'shared', 'network_drives'], 'expiry': None}], 'user_id': '<edited>', 'email': '<edited>', 'can_activate_backup_trial': True}
js: ResizeObserver loop limit exceeded

Looking logs, I found another error, when you try re-login with the alternative way, the installer app change again de defaults files (/usr/share/applications/defaults.list), with the corresponding muted errors:

WARNING:root:While reading /usr/share/applications/defaults.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 53, in __index_default_apps
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/defaults.list' [line 274]: option 'application/rdf+xml' in section 'Default Applications' already exists
WARNING:root:While reading /usr/share/applications/defaults.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 53, in __index_default_apps
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/defaults.list' [line 274]: option 'application/rdf+xml' in section 'Default Applications' already exists
WARNING:root:While reading /usr/share/applications/defaults.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 70, in __index_apps_for_mimetypes
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/defaults.list' [line 274]: option 'application/rdf+xml' in section 'Default Applications' already exists
WARNING:root:While reading /usr/share/applications/defaults.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 70, in __index_apps_for_mimetypes
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/defaults.list' [line 274]: option 'application/rdf+xml' in section 'Default Applications' already exists

Thanks for the support Insync Team! Great work!

Best regards,

1 Like