Insync on Plasma Wayland 5.18.3 on Archlinux not showing ui

Hi

i have this strange problem on Plasma (KDE) on Wayland in Archlinux. I can see the status icon in taskbar and it seems to synchronize fine but on double clicking the icon, I cannot see the UI. However, it works fine on Plasma X11. Can you please look into this?

Thanks and Regards
Amol Dandekar

Hi @Amol_Dandekar,

Can you let me know if running insync show launches the UI?

Hi, thanks for your reply.

No, insync show does not show the ui.

Regards
Amol

1 Like

I also see this error.

Launching with:
QT_QPA_PLATFORM=xcb insync start

works just fine, but not when using wayland

Hi!

Can you quit Insync then run insync start --qt-qpa-platform=xcb --no-daemon and let us know if it works?

If it doesn’t work, can you send us the output?

If it does work, you can modify ~/.config/autostart/insync.desktop and change Exec=insync start to Exec=insync start --qt-qpa-platform=xcb so that is will add that flag on startup.

Yes it is working now with the command you suggested. Thanks. I have changed the autostart entry.

Regards
Amol

1 Like

Is there any plan to make it run properly in wayland i.e without the flag?

2 Likes