Insync only start in wayland with xcb parameter

In Linux KDE Neon with wayland graphic session, Insycn only start if adding --qt-qpa-platform=xcb parameter.
If I run: “insync start”, it does not start
If I run: “insync start --qt-qpa-platform=wayland”, it does not start
If I run: “insync start --qt-qpa-platform=wayland/g”, it does not start
If I run “insync start --no-daemon” it returns “Using Wayland-EGL
/usr/lib/insync/insync: symbol lookup error: /lib/x86_64-linux-gnu/libEGL_mesa.so.0: undefined symbol: wl_proxy_marshal_flags”
If I run “insync start --qt-qpa-platform=xcb”, it starts well and I can use the app.

My system info:
Operating System: KDE neon 5.26
KDE Plasma Version: 5.26.5
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.8
Kernel Version: 5.15.0-58-generic (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 4800H with Radeon Graphics
Memory: 30.8 GiB of RAM
Graphics Processor: AMD RENOIR

lsb_release -c output:
Codename: jammy
apt-cache policy insync output:
insync:
Instalados: 3.8.4.50481-focal
Candidato: 3.8.4.50481-focal
Tabla de versión:
*** 3.8.4.50481-focal 100
100 /var/lib/dpkg/status

Hi @tafol.

I have escalated this issue with our engineer. Thank you for providing a detailed walk through!