Insync-portable selective sync, but tries to download everything


With the current version (1.2.12) of insync, running headless on raspberry pi. I’m having a problem - I have a large Google Drive account, but I only want to sync one small simple folder on to the raspberry pi. So I setup the account, do manage_selective_sync to choose the single folder I want, but insync continues to try and download or at least sync ALL of the folders in my account.

I’ve tried running manage_selective_sync before the main sync starts, by pausing it before adding the account, but it won’t then let you use manage_selective_sync correctly.

Is there a known way around this or to achieve what I want?

I’m sure I managed this before without InSync trying to initially download every single folder, but some reason this version has this behaviour of wanting to download / queue up every file, 150,000 in my case so takes quite a while.

Any points or suggestions?



@S_Snow Is Insync downloading your unselected files or is it just creating empty folders?


Hi There,
It seems to just be creating empty folders, but there are so many because of the size of my account I’ve not managed to wait for long enough (looks like it will take days) to get through them all.

I just want to get it syncing my one folder etc.

Any ideas?



I see. We are aware of this issue of Insync processing the old selective sync settings even if a new one was applied. This is compounded with the add_account command choosing to sync all files by default and not presenting the user with an option to select which files to sync first.

A workaround I can think of is the following:

  • Add your account on a machine with the Insync GUI. Choose to sync only the folder you want.
  • The location of the Insync folder should be the same as the location in your raspberry pi. For example, if you want your Insync folder to be located in home/pi/, it should be the same in the machine with the Insync GUI.
  • When Insync has synced your account stop it and copy the ~/.config/Insync/dbs and /home/pi/ folders to your pi.
  • Insync should now be set up correctly on your pi.

You should also make sure that the Insync versions on both machines are the same.

As for the main issue we’re working on other things at the moment, apologies for the inconvenience.


My issue is similar. Insync 1.2.17 on Mac. We have been syncing successfully for months on about 12 Macs. Recently, we added 1.5TB from a server to our Google Cloud account.

We shared it with everyone, but had everyone exclude it using selective sync. Despite the exclusion, everyone’s insync is processing over a million files that make up the 1.5TB. It isn’t downloading anything. Just slowly processing for days, with CPU’s running at 100%.


“The last reply to this topic is now over 183 days old.”
The problem is the same. I’ve installed a small server two days ago, currently none of my needed files synchronized, but I’ve 26000 empty folders while I need 550 folders with 5000 files…
I think, in headless mode the correct workaround will be if the add_account doesn’t synchronize any file or folder until I select some.


@blr: Apologies for the trouble. This is a little hard to implement in headless. Have you tried the workaround described?


No. I’m using Insync on many Windows and Linux desktop PC over a year (mostly without problem), but this was the first time on server. I didn’t think it’s a trouble…


I’m also hitting this issue, InSync starts up and tries to sync everything despite my very first action being to set selective sync on a single folder. Setting it up on a machine with a GUI and copying across the DB files is a painful workaround in the extreme. Is there really no other workaround? This issue has been open for some time now, can’t you add a command-line switch to the add_account command or something?


So far I have tried adding the account then immediately pausing syncing but then the selective sync dialogue gives me an empty directory tree so it seems I have to let it sync empty directories, then cross my fingers and hope that when I delete the empty directories it doesn’t then hit Google Drive and trash them on there, a risk I’m not prepared to take.


OK I stuck it out and waited for the empty dirs to sync, once it did so it deleted them all automatically just leaving the ones I wanted so while it wasn’t quite ideal, it did at least work despite looking like it was making a mess of things! Hopefully anyone else who comes across this will trust it a bit more as it did eventually work despite looking bad at the start. This was with the latest version available on the date of posting this (28th May 2016).


@Ian_Rawlings: Apologies for the trouble. This is on the list but there’s no ETA yet.


After 20 months, still without a solution? Really?
And why should we upgrade to Prime?


@George: Would an option to not download anything when adding an account do as a workaround? You can just select the files you want to sync after with the manage_selective_sync command.


This workaround is the most palatable of those suggested.


Hi, is there any progress on this request?