Insync status icon and Gnome 3.26


#1

Hey guys. Gnome has completely dropped status icons, and they have a new library (https://gitlab.gnome.org/External/libcloudproviders) to suport cloud sync apps. While insync does not suport this new library, what are your thoughts? How to keep insync running and visually with gnome 3.26? any alternatives?
The extension TopIconsPlus has been stopped developed.


#2

Tagging our engineer @jimperio and he will get back to you :slight_smile:


#3

I have the same problem.
I need status icon with nautilus inegration.


#4

Try this:
https://askubuntu.com/questions/966987/indicator-icons-do-not-appear-after-upgrade-to-ubuntu-17-10


Missing tray icon on Fedora 27 - cannot determine sync status
#5

Thank you very much, removing indicator-application did the trick for me! :smile:


#7

Gnome removed system tray. I just did man insync and all the information that I used the system tray GUI for, is available from command line. I am going to use the command line for now.


#8

Facing the same problem here … the Gnome extension TopIcons Plus adds tray icons to the top bar and it works (sometimes) … maybe wayland is part of the problem … you cannot rely on people on linux having access to tray icons … will you make the GUI available as an ordinary application?


#9

@jimperio looks like @jaduenas tagged you +2 moths ago, do you have any fix for this ?

Thanks so much.


#10

Looks like Insync is not willing to help their customers.


#11

I just updated to Ubuntu 18.04 and I have no access to your GUI in any way! Ubuntu comes with an appindicator extension that works for all apps, except insync for some reason. I also tried using TopIcons Plus, but nothing. This is a fresh install of Ubuntu so there’s no old Unity packages or anything similar.
I found a gnome extension (https://github.com/insynchq/insync-gnome-extension) that’s working ok, but I keep getting some error messages that I’m already running an instance of Insinc.

Hopefully the developers just fork that extension and make it available as the new way to use your app on Gnome shell


#12

Hi @fcastillo.ec,

Below are the common causes for the tray icon not showing:

  • sni-qt is not installed. Try installing it then restart your computer.
  • In some cases, when Insync is set to run at startup the tray icon is not shown. To confirm that Insync is running, run ps -ef | grep ‘insync start’; if there’s an output then Insync is running. In this case, try stopping then restarting Insync to see if the tray icon will show.
  • Sometimes an outdated video card driver could cause the tray icon to not show. Try updating your video card driver if possible and restart your computer.
  • When using GNOME Shell, legacy tray icons are moved to the bottom left of the screen. They are not shown by default, which makes them hard to find. To show them on the upper right try the TopIcons extension: https://extensions.gnome.org/extension/495/topicons/ (note that in recent versions of GNOME, tray icons have been disabled entirely)

Please let me know if none of the options above solve the issue. Thanks! :slight_smile:


#13

Hi @miamoran, I’ll address your list.

  • I had sni-qt installed all this time.
  • I do run Insync at startup. I have restarted it manually, but still no tray icon
  • I have an nVidia 1070 with the latest drivers from the nvidia PPA, v339
  • Given that I’m using Ubuntu 18.04, tray icons have indeed being disabled entirely and as I originally mentioned, I have tried TopIcons Plus and the default Ubuntu Appindicator extensions, and none work.

None of those options solves my issue, the only alternative is using the extension found on the GitHub repository, but it’s not stable and I see some errors often.


#14

Hi @fcastillo.ec,

Thank you for the feedback. :slight_smile:

Tagging our engineer @Kurt_Ko @beatobongco for assistance!


#15

So, I’m “suffering” the same issue. While it’s a pain in the back side to deal with the lack of a functioning tray icon due to Gnome developers thinking they know better, Insync, once setup, should need miminal assistance. If you need the interface, just issue an “insync show” on the command line to bring the window up. Maybe eve create an icon that you can double click that runs that command as a stop-gap measure.


#16

Hey @thehightechredneck,

We issued a response in regards to Gnome support here! You can check it for your reference. :slight_smile: