Insync thunar plugin doesn't work


#1

I installed Insync Thunar plugin (file downloaded: insync-thunar_1.2.3.35090-precise_all.deb), but nothing seemed to be working. That is, no sync icon is shown in Thunar. Did I miss anything? Thanks.

Ubuntu 14.04 LTS
Insync 1.2.3


#2

I run Arch and also have this problem. Errors with the install from the repository.


#3

yltang,

The Thunar plugin only provides context menu on right click. Unfortunately there is no straightforward way to set emblems on Thunar through a plugin.


#4

Grant,

What error is being raised? Did you install thunarx-python?


#5

Got it. Wait for such thing to happen …


#6

Thunarx-python is installed. No error; I just thought there will be emblems.


#7

This is what I get:
configure: error: in /tmp/yaourt-tmp-grant/aur-thunarx-python/src/thunarx-python-0.3.0': configure: error: no acceptable C compiler found in $PATH Seeconfig.log’ for more details
==> ERROR: A failure occurred in build().
Aborting…
==> ERROR: Makepkg was unable to build thunarx-python.
==> Restart building thunarx-python ? [y/N]


#8

Grant,

Do you have gcc or something similar installed? Building AURs requires some tools installed. Please refer here: https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites.


#9

Thanks for the pointer, I have now installed base-devel and downloaded insync-thunar but now get the message “Can’t download … parent is missing.”


#10

Please send your logs to support@insynchq.com for help in investigating the issue. They are the files logs.db and out.txt located at ~/.config/Insync. You can compress them before sending to save space.


#11

I have emailed the two files as requested. Thanks again.


#12

By the way, is there any plan to add emblems on Thunar like Nautilus?


#13

@yltang There’s no current way to add emblems on Thunar through its Python extension unfortunately.


#14

I run Debian Sid, how can I get thunarx-python?


#15

@LaPingvino Please try the one for Ubuntu 12.04 available here. If it works I will add it to our repo.


#16

Finally downloaded it from http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/pool/main/t/thunarx-python/ (via the reference in your link), and it actually works :slight_smile: .


#17

@LaPingvino That’s great. I’ve also finished added that package to our repo for Debian Sid so it will be available with no external dependencies.


#18

I am running Xubuntu on a 64bit machine. I first installed the 64bit package (insync_1.5.7.37371-artful_amd64.deb) for the insync client and it sort of worked but crashed a lot. I tried installing the 32bit client (insync_1.4.9.37127-artful_i386.deb) and it works fine.

I have also tried to install the Thunar integration package (insync-thunar_1.3.12.36116-precise_all.deb), but nothing seems to be happening. I was also admittedly expected emblems, but even aside from that, I have no right-click option. Am I doing something wrong?