.insync-trash folder


#1

Hello,

I have two problems. I hope you can help me. In version 1.3.1 you made this change:

“Selectively unsyncing now directly removes local files instead of moving them to ‘.insync-trash’. Thus, selectively unsyncing files will immediately free up your space.”

Since then I have not updated and I have kept using version 1.3.0 because for me it is important to keep a copy of deleted files in Google Drive in the folder ‘.insync-trash’.

In Ubuntu I have disabled the update and I have stayed in version 1.3.0. But in Mac OS the update is automatic.

My first question is: In Mac os, how can I disable the update in the app to keep version 1.3.0?

My second problem is that version 1.3.0 has a problem with the Google API. When a file includes in the name an apostrophe (’), for example the word “file’s” the file is not synchronized with Google and marks error. The way I’ve solved it is by removing apostrophes from file names, but that’s a problem.

My second question is: How can I correct that problem in version 1.3.0? Both in the Ubuntu app and the Mac OS app.

The ideal solution to these problems would be that in a new version of Insync the user can choose whether or not to have the folder ‘.insync-trash’, so that the user can choose to keep backup of files that are deleted in Google Drive or immediately recover the space by permanently erasing the files on the disk. That option would be very important.

But while that useful solution is not implemented in Insynq please answer my two questions in order to solve my problem.

Thank you!


#2

Let me tag our engineer @marte and he will get back to you.


#3

Please, I need an answer to be able to solve this problem.

Thank you very much.


#4

Hello NeuroStream, Insync still keeps copy of files that are deleted from Google Drive to .insync-trash as backup.

The change to not keep them in .insync-trash apply only to files that are selectively unsynced. By selectively unsyncing, Insync deletes the files locally, but it doesn’t delete the corresponding files in Google Drive. So in both cases (either deleted/trashed remotely in Google Drive; or selectively unsynced), there’s still a copy of the files.

For the apostrophe issue, I tried and it should be working on the latest version. Let me know if it doesn’t work on the latest one.

Thanks for your feedback.