Insync with Fedora 38 now missing icon (UPDATE: thread shares solution)

I just upgraded to Fedora 38 (GNOME 44) and while the Insync seems to work, the icon is now missing from the top bar.

When I run the “insync status” at the command line it says Synced.
I can also launch the GUI with search and it opens just fine.

It seems everything is OK except the icon is gone. Do you know how I can turn that back on?


Hi @cbmeeks! Just checking to see if your installed build has also been updated to our Fedora 38 build? :slight_smile:

How do I find that?

The version I have is:

Hi @cbmeeks,

Could you please run these two commands and post the output here?

dnf list installed | grep insync
cat /etc/os-release

dnf list installed | grep insync

insync.x86_64                       @insync     

cat /etc/os-release

NAME="Fedora Linux"
VERSION="38 (Workstation Edition)"
PRETTY_NAME="Fedora Linux 38 (Workstation Edition)"
VARIANT="Workstation Edition"
1 Like

Hi @cbmeeks, thank you! I received another report from a user, and have escalated it to our Linux Team. I’ll keep you posted!

FYI: I’m running Fedora 38 KDE Spin (upgraded from 37 KDE), and the Insync icon is in the tray in both X11 and Wayland as expected. I’m running version

1 Like

It must be a GNOME thing.

@cbmeeks It looks like it indeed. I’ll alert our engineers further on this lead.

A strange and similar thing here. I state that I am also using version

With Debian 12 (Bookworm) and Gnome 43.4 + X (No Wayland) with “Tray Icon Reloaded” Gnome Etension. This happens:

As soon as the system starts, everything works perfectly. BUT.
If I try to re -update X (with alt+f2 for example) then the icon in tray disappears.
The program continues to work properly but with no tray icon.

Thanks for the eventual help in resolution.
Have a nice day!

1 Like

Problem solved using another icon tray extension.
Appindicator (
It seems to work as it should!

I’ve tried the legacy app icon extension but it does not work.

Any updates on this? Preferably, Insync should be shown in the “background apps” of GNOME 44.

Hello! Following up on this with our Linux Team. Thank you for your patience, @cbmeeks!

Hi @cbmeeks

Can you try installing the gnome-shell-extension-appindicator package and then restart?
sudo dnf install gnome-shell-extension-appindicator

I’ve tried that before. It does not work.

It think the proper way to fix this is to enable the background app support in GNOME 44. I’m not sure how this would be done, but I would think this is should be a background app.

For example, Amberol (music player) supports playing music in the background and GNOME 44 can detect this. Then, it puts the icon in a nice “background apps” panel. This is what Insync should do.


1 Like

I don’t know what happened, but the icon is now showing. I recently updated my system (which I do regularly) and rebooted. I just noticed the icon was back.

Was there an update? It’s nice to see the icon back but it would be better if it ran under the “background apps” in GNOME 44.


1 Like

I also having the same problem after migrating from POP OS to Fedora 39.
The tray icon is a must guys… please look after.

Hi @noronhadaniel! Could you confirm your desktop environment on your Fedora 39 machine? Thank you!

sudo dnf install gnome-shell-extension-appindicator solve the issue, thanks.

1 Like

Thank you for confirming the steps you did to fix the issue, @noronhadaniel!