Insync wont start on Arch with i3

When I start insync with

insync start

I get no error and the process has a PID, but tray icon doesn’t show and

insync show

returns an error saying insync ins’t running

insync start --no-daemon returns

WARNING:root:While reading /home/maciek/.config/mimeapps.list
Traceback (most recent call last):
File “idesklinux/application_manager.py”, line 53, in __index_default_apps
File “configparser.py”, line 697, in read
File “configparser.py”, line 1096, in _read
configparser.DuplicateOptionError: While reading from ‘/home/maciek/.config/mimeapps.list’ [line 27]: option ‘application/pdf’ in section ‘Default Applications’ already exists
WARNING:root:While reading /home/maciek/.config/mimeapps.list
Traceback (most recent call last):
File “idesklinux/application_manager.py”, line 70, in __index_apps_for_mimetypes
File “configparser.py”, line 697, in read
File “configparser.py”, line 1096, in _read
configparser.DuplicateOptionError: While reading from ‘/home/maciek/.config/mimeapps.list’ [line 27]: option ‘application/pdf’ in section ‘Default Applications’ already exists
Exception in thread Thread-1:
Traceback (most recent call last):
File “threading.py”, line 980, in _bootstrap_inner
File “threading.py”, line 917, in run
File “idesklinux/app.py”, line 58, in start_core
File “idesklinux/platapp_impl.py”, line 28, in init
File “idesklinux/application_manager.py”, line 26, in init
File “idesklinux/application_manager.py”, line 82, in __index_apps_for_mimetypes
File “idesklinux/application_manager.py”, line 179, in __record_desktop_files
File “idesklinux/application_manager.py”, line 134, in __canonicalize_mimetype
File “xdg/Mime.py”, line 58, in lookup
File “xdg/Mime.py”, line 72, in new
AttributeError: ‘NoneType’ object has no attribute ‘lower’

my system is

System: EndeavourOS Linux x86_64
Host: 82RB Legion 5 15IAH7H
Kernel: 6.8.9-arch1-2
Packages: 2244 (pacman), 17 (flatpak)
Shell: fish 3.7.1
Resolution: 2560x1440, 2560x1440
WM: i3
Theme: Everforest-Dark-B [GTK2/3]
Icons: Everforest-Dark [GTK2/3]
Terminal: kitty
CPU: 12th Gen Intel i7-12700H (14) @ 4.600GHz
GPU: Intel Alder Lake-P GT2 [Iris Xe Graphics]
GPU: NVIDIA Geforce RTX 3070 Ti Laptop GPU
Memory: 5376MiB / 31822MiB

1 Like

Ok, I managed to downgrade from 3.9 to 3.8.7 and it works again. However I don’t really think it’s a proper solution to the problem, just a temporary hack.

1 Like

How did you downgrade to 3.8.7?

I had the source in the yay cache (~/.cache/yay/insync), so I removed 3.9 and used that to install 3.8.7.