"it seems that another Insync app is currently running.Will quit now"


#1

I wrote to Support about this 8 hours ago but they have yet to respond.

Installed Insync a couple days ago on a Ubuntu 16.04 system. Now when I try to start it, it says “it seems that another Insync app is currently running.Will quit now”. Indeed there is another instance running (as seen in ps -A output) and Google Drive sync is happening, but I can’t see or control it. It doesn’t show in the panel.


#2

Two days now and still no response from Insynch’s “awesome support”.

I killed the Insynch process and started a new one. That worked fine, the icon appeared on the panell.

Then I tried restarting. Same problem, it said "it seems that another Insync app is currently running.Will quit now” during login and it does not appear on the panel.

I certainly will not be paying for this after the free trial if it’s going to have bugs like this and no support.


#3

Hi @Richard_Holmes so sorry, it was the weekend. Let me tag our engineer @jimperio and he will get back to you.


#4

Sorry for the delay @Richard_Holmes. I’ve responded to your support email.


#5

@Richard_Holmes can you copy and paste their response here?


#6

Would love to see the response as well. Perhaps @jimperio can post it here? This is happening to me on a fresh install of Ubuntu 17.10. Files seem to be syncing but no control panel or anything. Thanks much.


#7

They asked about OS and desktop manager, but have not otherwise responded. It’s been a week. Not impressed.


#8

I’m having the same issue on ubuntu 16.04. For me the error message also pops up at startup, as if there are two calls for insync at startup.

In task manager I can see an instance of insync (not sure if it’s running or not). It seems like this ghost instance is blocking insync from actually starting. If I kill it, I can then start insync manually and it works fine. But is a very very annoying solution.


#9

I got a response this morning:

What seems to be happening is that while Insync starts, the tray icon for some reason doesn’t show up. By the way, what version of Insync are you currently using? And could you please share with me the logs at ~/.config/Insync/logs.db?

Unfortunately I’ve so far been unable to replicate your issue – using Ubuntu 16.04, Cinnamon 3.6.7, and Insync 1.3.22 OR 1.4.3.

For now, one possible workaround is to disable Insync from starting at startup (uncheck it from the Insync settings) and just manually start Insync.

If you upgrade to Insync 1.4.3, then another workaround is the newly-added show/hide commands, i.e.,

$ insync show
$ insync hide

I will continue investigating and let you know of any findings ASAP.

Not looking good. Free trial ends in 3 days, and I don’t intend to pay for something I have to manually start every time due to a bug.

(My bad not mentioning the Insync version, which is 1.3.22.36179, but really they should have asked for that and the logs at least a week ago.)


#10

I am getting this same problem.

The tray icon is not showing up and I therefore have no control over insync.

I am using a freshly installed Ubuntu 17.10.1 install and insync version

insync_1.4.5.37069-artful_amd64.deb

I too have paid for this but am getting disappointed in the issues for a paid product.

Someone (support) please help advise how I can correct this issue.
Thanks,
BLC


#11

I have a similar issue as well. When I ran Insync on Centos 7, the insync icon would show up on the bottom, tray, but with the stock installation of Ubuntu 17.10, I can’t see the icon anymore.


#12

@brettlc246 @karthik1024

Hi! Sorry for the delayed reply. :frowning:

Below are the common causes for the tray icon not showing:

  • sni-qt is not installed. Try installing it then restart Insync.
    *In some cases, when Insync is set to run at startup the tray icon is not shown. To confirm that Insync is running, run ps -ef | grep ‘insync start’; if there’s an output then Insync is running. In this case, try stopping then restarting Insync to see if the tray icon will show.
  • Sometimes an outdated video card driver could cause the tray icon to not show. Try updating your video card driver if possible and restart Insync.
  • When using GNOME Shell, legacy tray icons are moved to the bottom left of the screen. They are not shown by default, which makes them hard to find. To show them on the upper right try the TopIcons extension: https://extensions.gnome.org/extension/495/topicons/ (note that in recent versions of GNOME, tray icons have been disabled entirely)

If these do not solve the issue, kindly shoot us a message at support@insynchq.com with the link to this post.


#13

I am shooting you a message even though I don’t expect much, because I’ve emailed you before with no resolution.

You suggest:

“sni-qt is not installed. Try installing it then restart Insync.”

sni-qt is installed.

“In some cases, when Insync is set to run at startup the tray icon is not shown. To confirm that Insync is running, run ps -ef | grep ‘insync start’; if there’s an output then Insync is running. In this case, try stopping then restarting Insync to see if the tray icon will show.”

This certainly is what is happening, but you don’t supply a fix. Stopping and restarting Insync every time I log in isn’t a fix.

“Sometimes an outdated video card driver could cause the tray icon to not show. Try updating your video card driver if possible and restart Insync.”

Not the case.

“When using GNOME Shell, legacy tray icons are moved to the bottom left of the screen. They are not shown by default, which makes them hard to find. To show them on the upper right try the TopIcons extension: https://extensions.gnome.org/extension/495/topicons/ (note that in recent versions of GNOME, tray icons have been disabled entirely)”

Also not the case.

I am using Ubuntu 16.04 with Cinnamon.


#14

My story FWIW…

I installed Insync on Ubuntu 17.10 (variously upgraded from 16.04). The install went smooth, the icon appeared; everything synced properly.

Since a reboot, the icon did not appear.

Per the recently posted instructions, I installed sni-qt and rebooted. The icon has re-appeared and has continued to do so after subsequent reboots…so far at least.


#15

Tagging our engineers @beatobongco @Kurt_Ko for assistance! :slight_smile:


#16

Just an update on my end. Recently did a fresh install to 18.04 and installed insync. The icon wouldn’t even appear the first time or ever, even if I kill and restarted.

I installed sni-qt and it seems to be working now (haven’t restarted yet), but now insync seems to be missing the logo image. when I hover the cursor it says “Insync.py”
image


#17

I’ve installed Linux Mint 19. Problem seems not to be occurring now.


#18

Thanks for the update, @Richard_Holmes :slight_smile:


#19

Hey @nfournier

Sorry about that. Will confirm with our engineer and get back to you. Is it affecting file syncing by any chance?