Kde-neon: insync not working after changing into wayland session

When I changed my desktop from x11 to wayland (ie logout and login again into wayland), I found out that insync was not working (by looking at the icon tray). When I run command insync start --qt-qpa-platform=xcb --no-daemon, it produced no error. It also produced no error when I changed the start to show. BUT, if i reboot my machine and straight into wayland session, it worked.

And can you explain the use of --qt-qpa-platform=wayland/wayland-egl etc2…?


This is my system:
KDE neon User Edition 5.19 x86_64

Hi! I got your email as well :slight_smile: Currently waiting for our Linux team’s advise regarding this!

1 Like

I can confirm that it works on latest insync. and I also use --qt-qpa-platform=wayland for wayland support.

Thank you and keep it up.

1 Like

This appears to be an issue again. On top of the other problem where Insync isn’t auto-starting on KDE Neon (5.27), it’s not launching at all in Wayland sessions.

I tried using insync start --qt-qpa-platform=wayland but every command results in no error or response at all. I tried looking for a log folder, but it seems to be stored in a .db file that I don’t know how to open/interpret.

Let me know if I can supply any information to assist.

Thank you!

1 Like

I’ll escalate this to our engineers, @Yukigamine. I do apologize for the huge trouble! Could you please send your logs.db and out.txt to support@insynchq.com with the link to this post?

Hi @Yukigamine,

Did it resolve? If not,

Can you try running this:
sed -i.bak ‘s|^Exec=insync start$|Exec=insync start --no-daemon|g’ $HOME/.config/autostart/insync.desktop"

Let us know if Insync now starts for you on reboot

This resolved the same issue for me with freshly-installed KDE-neon 5.27.8

1 Like