[KDE Plasma | Wayland] Tray icon missing (with workaround)

Hello,

I’m using the latest release of KDE Plasma but I’ve been noticing this problem for a while now.

On Wayland sessions ONLY, no insync tray bar is shown, although the app itself is running.

It’s not even hidden, it’s just not available as an entry for display.

On an X.org session it works fine.

Any help?

Running the latest insync version from the arch AUR.

Thanks!

Hi @Andrea_Ippolito,

I have noticed a pattern with Wayland versus X.org sessions as reported by other users indeed, and thank you for sharing your feedback.

I will check this out with our Linux team. :slight_smile:

Try starting Insync from the command-line like this:

$ env XDG_CURRENT_DESKTOP=Unity insync start

If it works, then you can edit the desktop file accordingly.

The alternative is to install xembed-sni-proxy. edit: though if you have Plasma install then this proxy already should be available, so maybe make sure it was started.

1 Like

@tinywrkb thank you for this!! :slight_smile:

Thank you, I will definitely give it a try! :blush:

1 Like

Hello, I’ve tried this command and it works.
I’ve also tried to install the package you mentioned, but at some point it reports a conflict with plasma-desktop, which of course I want to keep :smiley:

My question now would be: is there any way that this can be improved on insync’s side?
As far as I understood the issue is caused by using xembed system tray icon (which is often referred to as “legacy”, at least in KDE community threads on the topic) instead of SNI.

Thanks a lot in advance, and have a nice day! :slight_smile:

1 Like

I’m sure this can be solved by Insync’s devs, but how much effort will this require is another question. Is this a Qt5 bug? Should Insync implement the SNI protocol and communicate via DBus? Some apps do this (e.g. iwgtk).

I suggest that you solve this locally.

Option 1: Edit the desktop file.
1.a. Copy the insync.desktop from /usr/share/applications into ~/.local/share/applications.
1.b Open the copied desktop file in a text editor, and change the value of the Exec key to env XDG_CURRENT_DESKTOP=Unity insync start.
Or just run desktop-file-edit --set-key=Exec --set-value='env XDG_CURRENT_DESKTOP=Unity insync start' ~/.local/share/applications/insync.desktop.

Option 2: Auto-start xembed-sni-proxy.
Check if you have /usr/bin/xembedsniproxy and then set your desktop to auto-start it.
If you can’t find it, then try locating it which xembedsniproxy.
In Arch Linux, this is already set to auto-start by shipping /etc/xdg/autostart/xembedsniproxy.desktop, so I believe that unless the user overrode it, then it should already be running. I’m not running Plasma on my daily driver, so I might be wrong here.

1 Like

@Andrea_Ippolito Thank you for your feedback! Let me check this with our Linux team further :slight_smile:

@tinywrkb Amazing assist as always!! Thank you so much.

No problem.
I feel that this kind of issues is something that could be catched if devs shift focus from testing different distros to testing different environments (X11, Wayland, DEs, WM).
This is why Flatpak is so nice, you don’t need to care about the distro anymore.

1 Like

Are you guys planning to publish insync on flathub? :pray::heart_eyes:

You make a strong point, and the team has been noticing that Flatpak requests are gaining more traffic as of late. Let me bring this up with Product :slight_smile:

1 Like

@Andrea_Ippolito No word yet from our engineers but I’ve raised the increasing requests about it to our team :slight_smile:

2 Likes