Linux RPI 3 armhf Insync error: [Errno 111] Connection refused

Hi All,

I’m using portable version of Insync for RPI 3 and as per the below link:

It was working fine after first use, the status was Syncing. As I have 107GB of data on GD I left it overnight. This morning when I checked the status I have the below:

pi@raspberrypi:~/insync-portable $ ./insync-portable get_status
Traceback (most recent call last):
File “”, line 76, in ipc_insync
File “”, line 224, in meth
error: [Errno 111] Connection refused

I restarted Insync and also rebooted the Pi but after resum_syncing I have the same status after few minutes.

Any Idea what can be wrong?

As I’m using it only for storing photos, accessing them on home network and syncing (all from time to time) I spin USB HDD down after 5mins of idle. Is this might be the problem?

Any suggestions are welcomed.


I applied the below fix as the error code was the same:

But still the same, still the same error.

Hello @Kruk07

Have you started Insync via ./insync-portable start?

Yes, I used this command .

Can someone please help me with the problem?

I paid for the product that is advertised as available at RPI and yet no solution or support.


I have started the insync with --no-daemon flag and it stopped now, no new movements so not sure if this is how it should be or just stopped:

pi@raspberrypi:~/insync-portable $ ./insync-portable start --no-daemon
INFO 2020-11-20 19:42:52,153 [init:info:1610] insync version: 67
INFO 2020-11-20 19:42:52,160 [init:info:1610] client created <ideskmain. client.Client object at 0x1700930>
INFO 2020-11-20 19:42:52,164 [init:info:1610] unix socket server thread start
INFO 2020-11-20 19:42:52,167 [init:info:1610] starting client
INFO 2020-11-20 19:42:52,200 [init:info:1610] LinuxFSWatcher._start
INFO 2020-11-20 19:42:52,207 [init:info:1610] Inotify loop enter
INFO 2020-11-20 19:42:52,222 [init:info:1610] Syncing GDUser(id=u’xxxxx’, email=u’xxxxxm’, name=u’xxxxx’).
INFO 2020-11-20 19:43:11,338 [init:info:1610] watch origin: /srv/dev-disk-by-label-Disk1/Google Drive
INFO 2020-11-20 19:43:42,487 [init:info:1610] GDUser(id=u’xxxxx’, email=u’xxxxxx’, name=u’xxxx’) (existing) is now being synced.
INFO 2020-11-20 19:44:14,216 [init:info:1610] No updater available.

Hi @Kruk07

Use the selective sync interface to select which items to sync. ./insync-portable manage_selective_sync [EMAIL]. Insync should be running when using these commands


Looks like it is working now but I think it was due to the missing setup for export option (ms-office).

I have another problem. Below command does not work:

./insync-portable set_autostart YES

Is there any way for insync autostart?


EDIT: managed to get this sorted with crontab.