.~lock. files aren't synchronized


#1

Hello,
I am on linux ubuntu 14.04 and I work with my team on .odt (open document, libre office, open office) files.
When one of my team on mac (without Insync) open an odt file, it creates an .~lock.xxxx.odt# file that is synced on my ubuntu. This file is useful to lock the file and prevent from double editing.
The trouble is in the case that I am editing an odt file it also creates an .~lock.xxxx.odt# file but it is not (never) sync to my team.
The result is that my team can modify the same file at same time.

Why Insync doesn’t sync an .~lock.xxxx.odt# file to Google drive?

Thank you per advance !!


#2

I am having the same problem with MS office files. The temp or lock files are not being copied over to google drive causing data to be saved over. Would love to find an answer.


#3

Hi @Chamblard and @DonnyHansen I will tag our engineers @lpugoy and @dipesh and they will get back to you :smile:


#4

Hello @Chamblard and @DonnyHansen,

Insync deliberately ignores the files that have their temporary, system etc. attributes set as it is usually undesirable to sync those files.

I will raise this issue with the team whether we should consider providing an option to allow syncing of such files to support this use case.

Thanks


#5

Thank you,
Do you know more about when adding this feature ?


#6

Hello @dipesh Have you got any news about this option?

Thanks


#7

This is a feature I would also be interested in. My password manager KeePassX creates a .lock file when the database is opened read-write. Synchronising the .lock file between machines is useful because the database will be opened read-only on the second machine preventing any conflicts.

It’d be useful if these were maybe implemented as default ignore rules instead so we can remove them if required.

Is there any status on this?

Thanks :slight_smile:

Edit: as a workaround, I have just created a copy of the .lock file on my second PC. I generally only open the database read-write on the first and remote desktop in if I need to make changes anyway, so this ensures that the database will always open read-only on the second PC. As a side affect of Insync ignoring temporary and lock files, the .lock file on the second PC will not be synced to the first PC so it doesn’t cause any problems.

Maybe someone else will find this workaround helpful. :slight_smile:


#8

@dipesh or @lpugoy,

Any update on a feature to enable syncing of temporary files? We frequently have files that for some reason get their temporary attribute set and thus do not sync. The files can be pdf, jpg, docx etc. There does not seem to be a reason. It would be great to disable this feature to not sync temporary files. Even if it was a registry setting that is fine with me.

Thanks!


#9

Hello,
This feature would be very useful for working in a team !!!
was It add to the road map ??
thanks


#10

When sharing python code (e.g. in jupyter notebooks) it’s helpful to share the Pipfile and corresponding Pipfile.lock to manage libraries used therein. The lockfile can be regenerated, but it contains the precise versions of dependencies so it’s useful to have it synchronized.

It would be helpful if default ignores are shown in the Ignore List section, especially if they can be disabled.