Move detection fails with large symlinked folders


#1

I have a folder on an external drive at
D:\folderA
It has a symlink in Insync at
Insync\folderB\folderA

I was trying to adjust the directory structure in Google Drive without changing anything on my external drive. In particular, I wanted to move folderA from
Insync\folderB\folderA
to
Insync\folderA

I tried this by
a) dragging the symlink on local computer, and
b) dragging the folder in Google Drive’s web interface

Both times, Insync failed to recognize the move, and treated it like a deletion+addition. I had to quickly pause and roll back Insync database to avoid damage.

I tried doing this with several of my symlinked folders (10-300 GB, 50-10000 files each), and quite a few had similar failure with move detection, but not all of them.
I cannot reproduce this error with newly created small test folders. With test folders, both methods can correctly move the folder with no problems. I’m not sure if it’s the size or the age of the folder & files that made a difference.

Logs sent in an email titled “log files for failed move detection”.


#2

Hey @Hawk!

Tagging our engineer @dipesh for your issue regarding symlinks. :slight_smile: