New Insync version: 3.0.19

Release notes:

  • Fix Google format files getting modified to the contents of link files
  • Linux: Fix issue where add account does not work in OpenSUSE

Windows 7 and later
macOS 10.10 (Yosemite and later)

Ubuntu (16.04 Xenial) & (18.04 Bionic)
Linux Mint (18.x) & (19.x)
Debian (8 Jessie) , (9 Stretch) & (10 Buster)
Fedora (27) , (28) , (29) & (30)

Finally this update works flawlessly on opensuse leap 15.1. Thank you for your excellent service!

2 Likes

I appreciate the progress you have made with 3.x

Can you please give us an estimate on when it will be possible to relocate Drive Team Shares on Linux? It already works for the private drive and it is quite strange having an application enforcing an unwanted folder right in the user home directory. The option was shown “under construction” in 3.014 (or around that version) but has since vanished completely.

Thank you.

Edit: Just took a closer look at it again. I also cannot find the option to change the private drive base folder. Can you please explain how this now works in general? Or did you remove all custom base folder settings? Currently my private drive definitely is in a custom base folder (although the option seems to have vanished in the UI)…on two different abbounts. But my team shares are stuck in the pre-defined base folder right in ~/Insync

Why I can’t find this update in the Fedora’s repo for openSUSE?

Guys I’m sorry but you need to stop and take version 3.0 offline.
I have been using Insync for 4/5 years now & have a paid account.

I upgraded today from 1.5.7 to 3.0.19 following your instruction article & kept existing folder & tried to upgrade/keep existing files.
The app loaded and started uploading a whole lot of my files again. Literally everything it said it was uploading.
On google drive web view I could see that not all but SOME old files WERE uploading again and creating duplicates.

I am a fan, I do like your work, but this is not acceptable.
Please take the software off and ask people to beta test it with large accounts lots of files and real world scenarios before publishing it to public and saying it is not a beta.

When you don’t label something Beta it is fair to expect it does not have basic bugs like duplicating files and that upgrading just works.
The bug I am talking about was reported by another user in 3.0.13 also as I just read so it is frustrating that it’s not fixed yet or labelled.

I am now downgrading to 1.5.7 and had to remove & readd my account as it said initialization failed so hopefully will not get the duplicate issue again here.

Please take this seriously and remove 3.0.19 from public or label it BETA and clearly inform customers that there are known bugs.
Nobody expects the software to be perfect but please take things seriously and put a BETA label on when you still have core bugs.

Using this software for work so it is frustrating and time wasting to have to do all this process and potentially mess up work files

2 Likes

What about thunar-plugin for Insync3? Users with XFCE desktop were dropped out during upgrade from Insync 1.5 to Insync 3.x? Common guys this is not standard behavior in a case of commercial App like this.

Just updated from 1.5.7 on Windows 8 - app doesnt work, there is only blank window on the screen.

@dimmm Just my personal recommendation: Do not use Windows 8!!! This version of Windows OS is really terrible.

1 Like

Just upgraded in Ubuntu to 3.0.19 and get:

Unexpected error doing ModifyCloudReg: The user does not have sufficient permissions for this file
Unexpected error doing AddCloudGDItem: Forbidden (repeated numerous times)

Worked great with 1.5 (I chose to keep the config)
Version 3 is very disappointing

2 Likes

I would like some clarification. I know the headless version is not being supported now, but does version 3 have command line options? Or are they defunct too?

1 Like

A terrible experience! I took a chance and installed version 3 and it all started to sync all the files over again. After some hours it was hanging, no more activity. Rebooting did not help. No use of a syncing service that don’t sync. And the worst: I was happy with version 1.5, why did I install version 3? Now I am back to 1.5, and now I have to sync all files once more… It take me days even when having 1000 megabits net. Uh!

2 Likes

I am having the same issue as @James_Gardiner but on Windows.

Is the version 3 broken?

1 Like

Finally works on Opensuse Tumbleweed. Synchronizing in the back (might take a while ;-))

Yikes. I can confirm. I thought that 3.0.19 just was " checking that there are no duplicates" but it is happily uploading all files from the base folder again creating roughly 250Gb in duplicates in the process.

1 Like

This version is an awfull mess, between buttons that don’t work, necessity of replicating everything that were previously replicated; symlinks that are no more taken in charge as they were properly. Of course on Archlinux nothing is supported (too few are we … but paid clients and it was working during years).
The better is often the ennemy of the good.

1 Like

Is there a plan to ship dolphin extension (something like insync-dolphin) via repos? I still see only caja, nemo and nautilus plugins available.

Three bugs I have so far.

  1. Deleted share point file.
  2. Wont sync upwards to sharepoint.
  3. Constantly reverts to default “base folder” rather than the one I set.

Worst upgrade of a linux program I have ever seen. Insync 3 has no command line interface? Are you kidding? This put a roadblock in my workflow and now I’m stuck and looking to downgrade back to Insync 1.5. You should LET PEOPLE KNOW when your “upgrade” removes functionality.

3 Likes

I’ve looked into this and it appears that there was a post (here: https://help.insynchq.com/en/articles/2853764-linux-headless-and-cli-community-support) saying that there will no longer be CLI support. Of course, no one frequents the Insync forums for fun on a Friday night, so everyone is likely to figure this out after a failure of their existing workflow forces them to look for answers. Come on Insync there should have been an email to everyone letting them know that if they upgrade to 3.0 they will lose CLI functionality. I think that Insync 3 should have been released as a different program rather than making it seem like an upgrade of Insync 1.5.7. Poor planning and rushing into this upgrade is causing a lot of pain for a lot of users, and Insync didn’t have the guts to just say what was going to happen in an explicit way. Shame on you all, and especially management.