No indicator icon Ubuntu 14.10


#1

Ubuntu 14.10, Insync 1.2.6 installed from .deb on a fresh install. Very simple issue: Insync is running and syncing, but I have no indicator icon. I’ve previously had an indicator icon working on Ubuntu 14.10 but after this install I don’t. Any thoughts?


#2

@danuary Please check out this page: https://forums.insynchq.com/t/how-to-solve-the-linux-issue-tray-icon-is-not-showing/44/1


#3

Done that; sni-qt is installed and latest version.
I’ve actually gone so far as to uninstall Insync (apt-get purge insync), move .config/Insync and the sync folder out of the way and reinstall. Now I have a different issue - seg faulting during the setup wizard as it “slides” to the folder selection screen.


#4

Please try running Insync through gdb to capture the backtrace when it crashes.

  • open a terminal
  • cd /usr/lib/insync
  • gdb --args ./insync start --no-daemon
  • in the gdb prompt, run “r”
  • when Insync crashes, run “bt” in the gdb prompt
  • send the output to us

#5

I’m having the same issue: Insync automatically starts and syncs correctly, the nautilus integration works, but I still get no indicator in the system tray. I’ve tried killing and restarting Insync, as well as purging and reinstalling it (including removing ~/.config/Insync). The latest version of sni-qt is installed, and I’m using the latest graphics drivers available for my machine. I’m running Insync v1.2.10.35142 on Ubuntu 14.04 (kernel v3.13.0-52-generic) on a Dell XPS13 (2015).


#6

The only way I was able to resolve this was to completely remove insync from the system - apt-get purge insync insync-nautilus, delete ~/.config/Insync, delete my sync directory, reinstall, and re-sync. It seems to be behaving since then. Somewhere in this process, however, I also upgraded to 15.04. So I can’t really say for sure if it was the Insync reinstall or the upgrade to 15.04 that did it.


#8

I suspect that it may have been the upgrade that fixed it for you. I have tried all the steps you mentioned apart from the distro upgrade with no success. However, on a different machine running Ubuntu 15.04 the indicator icon appears correctly. Unfortunately I don’t have the option of upgrading my XPS13 to 15.04 due to audio driver compatibility issues with the 3.19.x kernels.


#9

@alimuldal Are you using the Unity interface? If the issue occurs when logging in after logging out, that is a known issue and we’re already working on it.

When you run ps -ef | grep insync, is there an entry for Insync? If you then kill that process and run insync start --no-daemon, does the tray icon show? Is there an error in the terminal?


#10

OK running this:
~$ insync quit
OK
And then this:
~$ insync start --no-daemon
Shows the following errors
Fontconfig error: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 70: non-double matrix element
Fontconfig error: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 70: non-double matrix element
Fontconfig warning: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 78: saw unknown, expected number
QGtkStyle was unable to detect the current GTK+ theme.

I am successfully running Insync in Ubuntu 15.10 - with Unity. But there is no tray icon.
Did the issue ever get solved?
David


#11

OK - I’ve solved this problem thanks to http://www.webupd8.org/2015/05/on-demand-system-tray-for-ubuntu.html
The solution was ‘sudo add-apt-repository ppa:fixnix/indicator-systemtray-unity’
Then ‘sudo update’
Then ‘sudo apt-get install indicator-systemtray-unity’
Phew!
David


#12

very sad that I came here for support but I can’t start a new topic!
so,
I’m trialling Insync and I can’t manage to access the settings panel anywhere.
Also, when asked, I installed the Nautilus plugin (Gnome user here, on Fedora 27) but I can’t see any Insync app or file-browser.
If I click on the Insync application icon I get “It seems that another Insync app is running…” message.

Please, any suggestion?
Many thanks!