Rocky Linux 9 compatibility?

Hi,
I’m trying to get insync running for Rocky Linux. Hoping to get everything running smooth before I buy. I’m currently getting some errors on fc35. Am I doing things the best way?

Thanks,
David

sudo rpm -ivh insync-3.7.12.50395-fc35.x86_64.rpm
Verifying… ################################# [100%]
Preparing… ################################# [100%]
Updating / installing…
1:insync-3.7.12.50395-fc35 ################################# [100%]
error: can’t create transaction lock on /var/lib/rpm/.rpm.lock (Resource temporarily unavailable)
error: https://d2t3ff60b2tol4.cloudfront.net/repomd.xml.key: key 1 import failed.
Insync installation has finished. You may now start it.\n
fs.inotify.max_user_watches = 1048576

When I start it using insync start I don’t get a UI, same thing when I click the insync icon.

When I run: insync start --qt-qpa-platform=wayland --no-daemon
I get:
Failed to create wl_display (No such file or directory)
qt.qpa.plugin: Could not load the Qt platform plugin “wayland” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.

Aborted (core dumped)

Making some progress. I have insync-3.7.12.50395-fc34.x86_64.rpm installed and running with:
QT_QPA_PLATFORM=wayland insync start --no-daemon

give me the GUI

This is the output when I run the above command. Too many tracebacks and errors to be confident everything will work properly

[dostler@localhost Downloads]$ QT_QPA_PLATFORM=wayland insync start --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
QSocketNotifier: Can only be used with threads started with QThread
Using Wayland-EGL
WARNING:root:While reading /usr/share/applications/mimeapps.list
Traceback (most recent call last):
File “idesklinux/application_manager.py”, line 53, in __index_default_apps
File “configparser.py”, line 696, in read
File “configparser.py”, line 1091, in _read
configparser.DuplicateOptionError: While reading from ‘/usr/share/applications/mimeapps.list’ [line 331]: option ‘image/tiff’ in section ‘Default Applications’ already exists
WARNING:root:While reading /usr/share/applications/gnome-mimeapps.list
Traceback (most recent call last):
File “idesklinux/application_manager.py”, line 53, in __index_default_apps
File “configparser.py”, line 696, in read
File “configparser.py”, line 1091, in _read
configparser.DuplicateOptionError: While reading from ‘/usr/share/applications/gnome-mimeapps.list’ [line 331]: option ‘image/tiff’ in section ‘Default Applications’ already exists
WARNING:root:While reading /usr/share/applications/gnome-mimeapps.list
Traceback (most recent call last):
File “idesklinux/application_manager.py”, line 70, in __index_apps_for_mimetypes
File “configparser.py”, line 696, in read
File “configparser.py”, line 1091, in _read
configparser.DuplicateOptionError: While reading from ‘/usr/share/applications/gnome-mimeapps.list’ [line 331]: option ‘image/tiff’ in section ‘Default Applications’ already exists
WARNING:root:While reading /usr/share/applications/mimeapps.list
Traceback (most recent call last):
File “idesklinux/application_manager.py”, line 70, in __index_apps_for_mimetypes
File “configparser.py”, line 696, in read
File “configparser.py”, line 1091, in _read
configparser.DuplicateOptionError: While reading from ‘/usr/share/applications/mimeapps.list’ [line 331]: option ‘image/tiff’ in section ‘Default Applications’ already exists
INFO 2022-10-09 03:50:03,972 [mainlogs:_log_run:139] Core(app_version=3.7.12.50395, platform=Linux-x86_64-rocky/9.0) initialized
Using the ‘xdg-shell’ shell integration
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
INFO 2022-10-09 03:50:04,083 [app:start_core:65] core started
INFO 2022-10-09 03:50:04,084 [unix_socket_server:start:93] unix socket server thread start

Hi @dostler!

We currently don’t have a compatible build for Rocky Linux. Could you let me know if the Fedora 28 build works?

fedora 28 also works on rocky linux 9 when starting with “insync start --qt-qpa-platform=wayland --no-daemon”.
The window didn’t appear after startup and the window can’t be moved when click draging the title bar.

I went through and tried all the versions. fedora 33 seems to work best. The only things I noticed were that the GUI doesn’t start when I type insync start but it does start after clicking on the app icon.

I also get the following errors when installing:
error: can’t create transaction lock on /var/lib/rpm/.rpm.lock (Resource temporarily unavailable)
error: https://d2t3ff60b2tol4.cloudfront.net/repomd.xml.key: key 1 import failed.
Is this anything to be concerned about?

1 Like

@dostler Let me forward that error to see if this is something that needs troubleshooting, or can be disregarded for now :slight_smile:

@dostler Hello! Could you confirm what command you ran when you installed Fedora 33 on your Rocky Linux 9 machine?

sudo dnf install insync-3.7.12.50395-fc33.x86_64.rpm

@dostler Is it possible that there’s a background process using dnf/yum at the time you tried installing Insync?

I don’t think so. I’ve tried installing at least a dozen times on several different versions of Linux and I always get this message.

@dostler I see. Okay, I’ll check this out again with our Linux Team and update you here :slight_smile:

Hi, I’m just reinstalled my OS. This time I’m on Rocky Linux 8.7 and I installed with:

sudo rpm -i insync-3.8.0.50453-fc29.x86_64.rpm

After installing I get an error whenever I try doing anything with dnf:

Errors during downloading metadata for repository ‘insync’:
Status code: 404 for http://yum.insync.io/fedora/8/repodata/repomd.xml (IP: 143.244.49.180)
Error: Failed to download metadata for repo ‘insync’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

I think what is happening is that there is a variable that is looking for the fedora version and pulling version 8 because I’m on rocky linux verison 8 instead of fedora 29.

I changed the /etc/yum.repos.com/incync.repo and changed “$releaseserver” to “29”

It seems to have fixed the error and finds the fedora 29 file https://yum.insync.io/fedora/29/repodata/repomd.xml

Just wondering if this is a safe practice or if this is going to screw something up down the road?

Cheers,
David

1 Like

Hey! Thank you so much for sharing your workaround. I have reached out to our engineer to see if there would be any potential issues.

Hi All,

Red Hat 9 user here. I was able to get the insync gui to start by temporarily switching to X11 instead of Wayland. I believe there is an issue with the insync provided libraries causing the incompatibility with Wayland on Red Hat 9 (and alike distros). I haven’t had an opportunity to pinpoint which of the insync provided libraries are causing this issue.

On my Fedora 37 machine, the gui launches perfectly fine under Wayland.