Segfault libpython3.7m.so.1.0

I am using Gentoo Linux amd64.
Each time I start Insync it crashes immediately with this message in dmesg
`insync[12899]: segfault at 1e8 ip 00007f2f680b9f64 sp 00007ffe344fef90 error 4 in libpython3.7m.so.1.0[7f2f68054000+17e000]

Code: 57 10 48 89 77 08 48 c7 07 01 00 00 00 c3 0f 1f 84 00 00 00 00 00 e9 7b b4 f9 ff 66 66 2e 0f 1f 84 00 00 00 00 00 53 48 89 fb <48> 8b 7f 20 e8 f3 be f9 ff 48 85 c0 74 0e 48 89 58 08 48 c7 00 01`

Hi @kankro,

We’ll update you on this as our engineer will need to test on a Gentoo Linux setup similar to yours. Could you confirm what version you have at the moment?

Thank you for your patience!

Hi @miamoran,
I am using Insyc version 3.3.5.40925 but I tried others with no success. Are there any requiremets for Insync to work? Maybe I am missing some other dependencies installed? However Insync used to work properly in the past.

Hi @kankro :slight_smile:

Gentoo is not officially supported, but may I know what the exact installer was that you tried?

You should describe how you did install Insync: custom ebuild or just manual ?

I think Insync should not support Gentoo as there are as many versions of Gentoo as there are Gentoo users (otherwise that would defeat the purpose)

About your error message: I have seen this exact message when I tried some custom ebuild (do not remember where I have found it, probably on http://gpo.zugaina.org/. The issue was with Gentoo stripping every shared library by default. You can disable this behaviour by adding RESTRICT=“SPLIT” to your ebuild

@eber42 THANK YOU. I googled the error a lot but didn’t came across RESTRICT=“SPLIT”. Now everything works fine.

@eber42 You are heaven sent for helping out!! Many, many thanks for your reply, I truly appreciate it. :slight_smile:

@kankro I am glad to know this has been sorted out on your end!