Signature error on KDE Neon

Currently, I have Insync installed on 2 computers. The first is a Kubuntu 20.04 install. No problems with that one. The 2nd is a 20.04 based KDE Neon install. When I run “sudo apt update” on this machine I get the following errors.

Err:5 http://apt.insync.io/neon focal InRelease
403 Forbidden [IP: 52.217.8.52 80]
Get:6 http://archive.neon.kde.org/user focal InRelease [117 kB]
Reading package lists… Done
E: Failed to fetch http://apt.insync.io/neon/dists/focal/InRelease 403 Forbidden [IP: 52.217.8.52 80]
E: The repository ‘http://apt.insync.io/neon focal InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.

I am able to get around this by adding [trusted=yes] to the entry in /etc/apt/sources.list.d/insync.list

Obviously, that’s not a good solution, so I’ve actually commented that line out for now. That means I won’t be getting any updates.

How can this be remedied?

IMHO the best solution would be to prioritize flatpak development as proposed elsewhere on the forum. I’m dearly hoping a flatpak may come.

But perhaps something more immediate can be done.

Please help.

Thanks!

Hi! Thanks for bringing this to my attention. I’ve raised this to our Linux team and will update you on the next steps to take!

EDIT:
We’ll update the repos-- it should work afterwards. :slight_smile:

Hi! Repos have been updated-- can you try this again @aaylnx?

I did not look back here for a few days, but, yes, I’m getting no errors now. Thanks!!!

Still hoping for a Flatpak release one day though!

1 Like

Well, it did work for a while without any errors, but now, suddenly, I have key errors again. Here’s the output.

Err:7 http://apt.insync.io/neon focal InRelease
The following signatures were invalid: EXPKEYSIG A684470CACCAF35C Insynchq Inc services@insynchq.com
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://apt.insync.io/neon focal InRelease: The following signatures were invalid: EXPKEYSIG A684470CACCAF35C Insynchq Inc services@insynchq.com
W: Failed to fetch http://apt.insync.io/neon/dists/focal/InRelease The following signatures were invalid: EXPKEYSIG A684470CACCAF35C Insynchq Inc services@insynchq.com

Can you advise?

Same signature issue on PopOS (Ubuntu) for the last two days. Thanks!

Hi! Please run this for APT:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys ACCAF35C

Let me know if the issue persists!

2 Likes

Fixed it on my Kubuntu 20.04 system. Do you guys have a status page where you can pre-notify us when this is going to happen in the future? APT key changes are… obviousy disruptive.

I’ll bring this up with our Linux team, I appreciate your feedback and understand your sentiments regarding the issue.

I had the same issue on Debian stable, the fix worked

2 Likes

I had the same issue in Ubuntu 18.04.04.5 + Mate

The fix worked. :+1:

This seems to have fixed the issue for me. Thank you.

I still hope that one day a Flatpak version of the app can be developed. The universal aspect of Flatpaks would keep this problem for happening, since various package management systems handle it in a variety of ways. Also, it would make installing Insync on any Linux system much easier. Thanks again.

2 Likes

Thank you very much, Buddy. I finally managed to fix my mistake.

1 Like