[SOLVED] Some Ubuntu 18.04 instance do not appear Insync icons


#1

Hello Insync teams and users,

I am operating Insync in several computers (both Windows and Ubuntu) and some of these instances have problems on icon appearance.

The problem is simple: tray icon do not appear on Ubuntu 18.04.
Insync itself is running flawlessly according to reply from command line interface (sharing, downloading, uploading, …). And very curiously, this symptom happens on my two notebook machines; ThinkPad X220 and ThinkPad X1 Carbon (2015=3rd). Other Ubuntu 18.04 instance (desktop computers) have no problems on icon.

I wonder this trouble may be due to lack of some related packages … desktop computer has it (them) and notebooks not. Of course, as it is just my speculation, the cause may be different.
Is there any solution to detect the cause of problems, and even solve it ?
Thanks all for cooperation.

(Machine info) Two ThinkPads are dual-booting machine, Ubuntu and Windows. Ubuntu 18.04 and Windows 10. Both Ubuntu 18.04 instance is upgrade from 16.04.


#2

Partly self-solved.

Invoking this command solved the problem.

sudo killall indicator-application-service

Maybe removing package “indicator-application” will solve the problem permanently.

(Reference: https://askubuntu.com/questions/966987/indicator-icons-do-not-appear-after-upgrade-to-ubuntu-17-10)


#3

Hi @terakin,

My apologies for the delayed response!

Can you try installing the AppIndicator as mentioned here? Let me know how it goes!


#4

Mia,

I don’t install “AppIndicator Support” as mentioned in here. Instead, I use TopIcons Plus, a GNOME extension which maybe has similar function. Anyway, this extension has no effect for this problem (no change for enabling/disabling the extension).


#5

I have finally solved the problem.

The solution is, as mentioned before, to disable appindicator service.

For temporary solution, invoke this command,

sudo killall indicator-application-service

If it works, proceed to the complete and permanent solution to remove the appindicator package.

sudo apt remove indicator-application

I could grab back Insync icon by this step.

If you do not still have Insync icon in your task tray, try more complete solution to remove other package related to appindicator.

sudo apt remove indicator-appmenu
sudo apt remove indicator-bluetooth
sudo apt remove indicator-common
sudo apt remove indicator-datetime
sudo apt remove indicator-keyboard
sudo apt remove indicator-messages
sudo apt remove indicator-network
sudo apt remove indicator-power
sudo apt remove indicator-printers
sudo apt remove indicator-session
sudo apt remove indicator-sound
sudo apt remove indicator-transfer
sudo apt remove indicator-transfer-download-manager

(Of course, you can execute these package removals with one command by lining all packages in apt.)

According to the discussion in AskUbuntu, the Ubuntu update sometimes fails to remove these obsolete packages and they make tray icon behavior mess.