(SOLVED) The repository 'http://apt.insync.io/ubuntu impish InRelease' is not signed

New 21.10 build and can’t launch InSync witht eh 21.10/deb build. It looks like it installs fine, but then when I try to launch, nothing happens.

Running CLI Update shows the following:

E: Failed to fetch http://apt.insync.io/ubuntu/dists/impish/InRelease 403 Forbidden [IP: 80]
E: The repository ‘http://apt.insync.io/ubuntu impish InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Hi @jhmariscal! Could you give this another try please? We’ve just updated our repository over the weekend to address this issue. Thank you!

I get the same error message. It seems not to be fixed.
Ubuntu 20.04 recently installed
Merry Christmas and hopefully get a fix before next year :wink:

1 Like

I am also getting this error on Kubuntu 21.10. I have this in my sources:

deb [arch=amd64] http://apt.insync.io/ubuntu impish non-free contrib

And I am getting exactly the same error. When I try to use the browser to get to that address, it also gives me 403 - it seems to me the repository is down. And judging by the results I get for this when googling, this is farily common. Why is that?

Mine is:

deb http://apt.insync.io/ubuntu Focal Fossa non-free contrib
if you visit the link you get an XML code I can’t post here. (is there no way to post code here?)
It contains the lines:


Hi all! Let me bring this up with our Linux team :slight_smile: Thank you for the patience, and happy holidays!

@klabog Hi! Could you replace “Focal Fossa” with “focal” (all lowercase and without the quotation marks)?

Thank you! This solved the problem!

1 Like

Hi @drew – could you send the output of sudo apt update? :slight_smile:

As I said, it was exactly the same error as OP’s. But, based on what klabog said, I removed /etc/apt/sources.list.d/insync/insync.list and when I placed

deb [arch=amd64] http://apt.insync.io/ubuntu focal non-free contrib

into my /etc/apt/sources.list, it now works. So the problem seems to be that insync places a wrong line into the sources.list.d directory - there are no packages specifically for impish.

Hey @drew! I’ll send this update to our engineers and follow up on the impish packages. Thank you so much for the redirect.

Hi @drew

Can you try replacing focal with impish in your /etc/apt/sources.list?
As our Ubuntu impish repo works fine for me

Indeed, now it works.

1 Like

Thank you for confirming, @drew! Glad it’s working on your end now.