Some packages could not be installed


#1

I’m tyring to update insync headless on ubuntu 18.04 but I’m getting this error message:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
    
The following packages have unmet dependencies:
insync : Depends: libc6 (>= 2.26) but 2.23-0ubuntu10 is to be installed
E: Unable to correct problems, you have held broken packages.

I don’t know what version I’m currently running because I can’t figure out how to check the version. I can’t find a command line command to get the version information.

What version should I be running with Ubunut 18.04.1 LTS 64 bit?

I updated my apt insync.list file to read as follows:

deb http://apt.insynchq.com/ubuntu bionic non-free contrib

What are your recommendations?


#2

I’ve upgraded to Ubuntu 18.04.1 LTS 64 bit and now insync won’t start at all. I’ve tried both xenial and artful versions and neither one will start. I’ve tried starting as myself and with sudo. Nothing I do will make it start.


#3

Hi @Don_Lund,

Could you run insync start --no-daemon and send the output here?


#4

Here you go. Thanks.

Traceback (most recent call last):
File “<string>”, line 6, in <module>
File “main.py”, line 128, in <module>
File “main__insync.py”, line 125, in <module>
File “isyncd/linux/headless/cli.py”, line 49, in run
File “main__insync.py”, line 34, in main
File “PySide2/QtWidgets.py”, line 26, in <module>
File “PySide2/QtWidgets.py”, line 17, in _bbfreeze_import_dynamic_module
ImportError: libGL.so.1: cannot open shared object file: No such file or directory


#5

Hi @Don_Lund,

As per our engineer, your output says it can’t find the file libGL.so.1 since this is used for showing graphics stuff on the screen. May I confirm if you’re on a terminal-only setup? If so, kindly uninstall the insync package first, and then install insync-headless. Let me know how it goes. :slight_smile:


#6

OK. I’ve removed insync and installed insync-headless. How can I be sure it’s running and actually syncing files? Whenever I run insync-headless get_sync_progress it says there are No syncing activities.


#7

Hi @Don_Lund,

insync-headless doesnt sync right away, you have to select which files you want to sync using insync-headless manage_selective_sync [EMAIL]. Just make sure to add your account prior to running that command.

Here’s our CLI help guide for reference: https://help.insynchq.com/installation-on-windows-linux-and-macos/advanced/linux-controlling-insync-via-command-line-cli

Thanks!