Still no menu in systray icon


#1

1.4 beta version number: insync_1.4.1.37037-artful_amd64.deb
Operating system: Ubuntu 17.10

Issue:
I posted here about this issue, affecting insync 1.3, quite a long time ago. Your systray icon is implemented with the discontinued xembed protocol. The reply at the time was that this would be addressed in an upcoming release. Yet, here we are with the same problem in insync 1.4.

xembed support has been dropped from many desktop environments, and replaced with D-bus protocols for interoperability. See, for example:

https://lists.fedoraproject.org/pipermail/devel/2014-March/196343.html

(and this is several years old!)

The net result is that an icon appears in the systray, but you cannot click on it! Or, at least, clicking on it has no effect. This means trying to configure insync using the insync-headless command, which is poorly documented.


No tray icon in ubuntu 17.10 (solved)
#2

thanks for reporting @iestynapmwg. Tagging our engineers @jimperio @marte


#3

@iestynapmwg I’m terribly sorry for not getting back to you sooner! We will take a closer look at this – it can probably be fixed by updating the Qt library that we use.

Just so we can more easily replicate the issue, may I ask for more details on your setup? What desktop environment are you currently using and how are you displaying the Insync tray icon currently on Ubuntu 17.10?


#4

Hi,

I’m using the Enlightenment desktop (version 0.21.10). I’m using the built-in systray module, displaying it on the desktop:
Settings > Gadgets > Background > Configure Layer, then add Systray
(the systray module does have to be loaded, if it’s not already)

After starting Insync, the icon appears in the systray. Left clicking on the icon does nothing. Right clicking on it (or anywhere in the systray) brings up the systray settings.

Here’s hoping you can fix it :slight_smile: The insync-headless program is not easy to use, as i have to guess at the syntax most of the time.


#5

Hi guys, Arch Linux + GNOME user here.

I was finally able to solve this issue now! I already had sni-qt installed, which wasn’t making the icon show up, however I noticed someone saying about conflicting indicators apps, so I went on and uninstalled libappindicator-gtk3 and libindicator-gtk3 - which I had installed a long time ago - and the icon started showing up after starting the session.

I don’t know exactly what’s happening, since I wasn’t able to inspect any logs that might lead to the clues, but my guts tell me insync might be trying to use libindicator-gtk3’s API first instead of sni-qt and end up “thinking” that it’s already showing up. In other words, libindicator-gtk3 might be tricking insync that it’s showing up properly, when it’s actually not.

Cheers!
Diogo