Sync of exectable files

Sync of file permissions don’t work, especially the execute bit. There is an issue that was closed a year ago addressing this issue.

It is still not working!
I am running:
Ubuntu 23.04

If you need any logs let me know. I did a tail -f on the out.txt while it changed, but nothing is added. I ran a ls -l loop on the file while changing it on an other pc. The permission changes when I am trying to actually execute the file.

Hello, and apologies for the trouble! I have escalated this issue with our Linux Team for further advise.

1 Like

Hello @Tore_Martin_Hagen! As per our engineers, that is a limitation of cloud storage; there’s no way to store the file permissions in the cloud.

One possible way is for users to write a bash script that would do that.

Hi. @mia
This can easily be fixed by inSync. When syncing an existing file from the cloud to local storage then just preserve the current permissions. This is the default behavior in Linux already when you copy a file to an existing one

:/tmp/tull$ ll a b
-rwx------ 1 tore tore 4 Jun  5 08:01 a*
-rw-rw-r-- 1 tore tore 4 Jun  5 08:02 b
:/tmp/tull$ cp b a
:/tmp/tull$ ll a b
-rwx------ 1 tore tore 4 Jun  5 08:02 a*
-rw-rw-r-- 1 tore tore 4 Jun  5 08:02 b

So instead of just open the file with default permissions and overwrite it when syncing from the cloud, you have to either make a local copy and copy it, or maybe better, get the current permissions and then set it on the file afterwards.


Thank you for raising this; I’ll have our engineers look into it!