Syncing broken/incomplete with version

Two Ubuntu 18.04.3 systems (64-bit both).

Insync app version on both.

I change some files on one of systems, some files are synced and copied to other Ubuntu, some other aren’t. After I ran comparison of ‘find . -type f | sort’ on both sides, I found 6 files missing on one system, 8 on another. That’s definitely not good.

How am I supposed to handle that, apart from copying/updating files manually every time?

Is it a command/way to force syncing files missing on Google Drive (or vice versa)?

Hi Konstantin,

Can you send over your config folder, and the files that did not sync to

Please do include the link to this post so we can refer to it as well.

The files list beneath ~/.config/Insync:


Which of them shall I send?
How many of them contain sensitive information (such as passwords etc)?
How do I send them (by email?)

ATM, I have to do rsync both directions every time I change the affected directories. The problem wasn’t solved by 3.0.21.

I’ve given Version a try. Likewise, still not syncing my files, causing massive problems. Interface locks up and starts flashing. Still not useable, brand new Windows 10 instal…

Back to 1.5. Really need to fix this folks!!!

I sent you the info.

I’d check those logs carefully. The /data/ ones contain a list of every file on your system and the file name, and I think the config.db (don’t remember now) has the oauth refresh token in it which I would suggest revoking and renewing if you sent it in.

OK, how exactly I refresh the token, without completely removing and re-adding the account?

I don’t honestly know. Step 1 will be revoke the existing oauth grant in Google Drive, but to make a new one for inSync without basically deleting and re-adding your account, inSync would probably have to comment.
It might be possible to use their alternate login method (you go to and sign in and you get the new OAuth token) and manually inject that code into the DB where the old token was, but I don’t know OAuth or inSync in depth enough to know if inSync will care about the difference between an access token and a refresh token in that DB.
This is assuming the files you sent had the refresh token in them. I don’t know which of the files you actually sent in.

Thanks for comment.

I’d prefer to get the Insync developers’ comment on that. I have enough things to do, to add re-adding and re-syncing all the affected devices.

So far, the situation is this: separate Insync installations stopped downloading new files from Google Drive.

I have to rsync those manually - thus doing what Insync was supposed to do.

Could developers comment this somehow?

The problem (no new files synced from one device appear on others) still persists, after upgrading to

This issue was resolved for me in on Windows 10 Pro 1903. I believe I rebooted before testing. Insync is now auto syncing all files I create both in the cloud and uploaded to the cloud from other devices.

It’s possible the issue has only been resolved in Windows. Assuming the Ubuntu gui is the same, you can check to see if the setting is enabled. I posted a screenshot of it here if that helps: Items created in cloud don't auto sync locally

Thanks for response, @kyle - the mentioned setting is checked in Ubuntu client as well, but new files still aren’t copied from the cloud on either Ubuntu installations I use.

I don’t use Insync with Windows, so I can’t comment on that.