The user interface is not able to display properly

I’m using the Insync on Arch Linux.

The problem I meet now is that the user interface is not able to display properly. I think it may be a problem of scale.

Here is my system information:

[bryan@Bryan-YOGA14s ~]$ neofetch
OS: Arch Linux x86_64 
Host: 82MS Yoga 14sACH 2021 
Kernel: 6.1.4-zen2-1-zen 
Uptime: 15 mins 
Packages: 806 (pacman) 
Shell: bash 5.1.16 
Resolution: 2880x1800 
DE: Plasma 5.26.5 
WM: kwin 
WM Theme: Breeze 微风 
Theme: [Plasma], Breeze [GTK2/3] 
Icons: [Plasma], breeze [GTK2/3] 
Terminal: konsole 
Terminal Font: Hack 13 
CPU: AMD Ryzen 7 5800H with Radeon Graphics (16) @  
GPU: AMD ATI Radeon Vega Series / Radeon Vega Mobil 
Memory: 2587MiB / 13824MiB 

And I am running KDE on Wayland.

Here is the screenshot of the problem:

I found a workaround. Run the Insync in the environment QT_QPA_PLATFORM=xcb , and the problem will be gone.

1 Like

Thank you for updating me on what you did to remedy the issue, @FrankD.

Would you like us to look into this further and see what happened prior to your workaround?

Yes, it would be better if Insync can run normally without any workaround.

Sure thing, I’ll check this out with them and see what affected the UI initially. Much thanks for reporting this, @FrankD!

I find a better solution.

Run insync in the enviroment QT_AUTO_SCREEN_SCALE_FACTOR=1.

The previous solution also needs to set the proper zoom in the setting menu, the now one doesn’t need it. And I think this bug is related to HiDPI