Token has been expired or revoked

I am getting the following message quite frequently when syncing from GoogleDrive to Ubuntu Linux when using headless insync.

“Token has been expired or revoked”.

The I have been repeatedly removing and adding the account, but it will run for a little bit and then stop working with the message.

Any help would be greatly appreciated.

Hi @mbrannigan,

Thanks for reporting this! This is a known bug we’re trying to solve. To help us investigate this issue, please do the following once the issue pops up again:

  • Collect the 1st set of your log files (logs.db, out.txt) after Insync is closed
  • Re-authenticate your account by clicking the (+) beside your account avatar as shown here.
  • Collect the 2nd set of your log files after Insync is closed when the authentication token error message pops up again.

Send sets 1 & 2 of your logs to with the link to this post. Thank you!

I have sent this information to support. Is there any update on the fix for this? I purchased the yearly license for insync-headless specifically to synchronize Google Drive.

1 Like

Hello @mbrannigan,

This is included in our priorities given that it’s a long-standing issue already, which seems to be triggered after a system restart. I checked your email thread with my colleague, and I wanted to ask if your Google account is part of a Google Workspace?

Hi Mia

I do not believe that my account is a Google Workplace account. I do have Google One. I am unable to initialize a complete sync even when I do a fresh install of the product. Let me know if you need any additional information.

Thanks for your help.

i am facing the same problem. i have a google one subscription and since yesterday i am on the basic plan using insync3-headless on my debian machine. as i had to reinstall the machine from scratch i am now trying to do the inital sync of about 1tb of data (before the crash of my machine i was using insync-headless with legacy plan, so all data exists on my local hard drive and on google drive in perfect sync). installation, adding account, base folder, etc went smooth so the sync started today in the morning. me just checkiing sync progress from time to time. in the afternoon i got the sync status: error and further investigation turned out „authentication token expired“. i was able to renew the token pretty quick as insync-headless error threatment offered me a login option. problem solved but there is still a strange feeling when will this happen again… @mia: if you are interested in log files just ask. i am willing to provide them.

@Peter_Altherr Hi! Logs would be much appreciated, please! Do send them over to your existing email thread with (or start a new one if you prefer!).

@mia hey, finally i was able to extract to set of logs from two different days. i have shared them via my google drive and have sent an invitation to containing further instructions how to download and uncompress the log files. i tried sending by email but the package is too big as an email attachment.

I got the invite link @Peter_Altherr. Thank you so much for notifying me here!

Same here. I’m a Google Workspace user (and admin). I had the same issue after a restart. I’m currently evaluating InSync. Please let me know if I can help.

Hello @Marbot! I have responded to a related thread: Your authentication token has expired. Please try logging in again

Thank you very much!

after not touching my debian machine for quite some days i did this:

insync-headless status

i got this error message:

Traceback (most recent call last):
File "insynclinux/headless/", line 19, in <module>
File "click/", line 1130, in __call__
File "click/", line 1055, in main
File "click/", line 1657, in invoke
File "click/", line 1404, in invoke
File "click/", line 760, in invoke
File "insynclinux/headless/", line 360, in status
KeyError: 'subscription-expired'
[939530] Failed to execute script insync-headless

very strange, as i have purchased a license recently.

after rebooting the machine:

insync-headless version shows

insync-headless status brings up the same error message as shown above.

Hi @Peter_Altherr,

This version uses a different licensing model, hence the error message. Your license is active on v3.8.4. My email from about ~3 weeks ago provided a breakdown re: licensing inquiries. Just wondering if you received that :thinking:

dear mia, i have found the email. so according my license i have to switch from insync-headless to the insync package, right? if so, is there anything to be aware of as i have a half synced insync-headless installation/configuration or is it fine to just uninstall insync-headless and delete /root/.config/insync-headless folder?

Hi @Peter_Altherr :slight_smile: Great question. Allow me to clarify to ensure a seamless transition for you.