Ubuntu 18.04 LTS Repository Issue - apt-key fails

Using the command below fails, with invalid argument.

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys ACCAF35C
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys ACCAF35C
[sudo] password for *****: 
Executing: /tmp/apt-key-gpghome.I5rQFm9bxA/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys ACCAF35C
gpg: keyserver receive failed: Invalid argument

Digging into this, I tried to manually download the certificate and add it, but it appears that the key “ACCAF35” doesn’t exist on the Ubuntu key server, so it cannot be added.

Manual Search on the keyserver.ubuntu.com

Technically it looks like I can still pull updates, but the error is annoying and this really should be corrected.

Hi @originalme8

You can find our key here: https://keyserver.ubuntu.com/pks/lookup?search=services%40insynchq.com&fingerprint=on&op=index


@Kurt_Ko even installing the key manually using the command below does not resolve the issue. There is something off with the Certificate and the repo for Ubuntu 18.04.

wget -q "https://keyserver.ubuntu.com/pks/lookup?op=get&search=0xaeeb94e9c5a3b54ecfa4a66aa684470caccaf35c" -O- | gpg --dearmor > insync-0xa684470caccaf35c.gpg

@originalme8 Tried out the command you posted and works fine in a fresh Ubuntu install
Might be an issue with your config or the keyserver itself may have issues.
What are the contents of your /etc/resolv.conf file?


It looks like my repo entry had a typo and was doing something odd.