Ubuntu 18.04 LTS, this location is empty

Suddenly, Insync is saying I have no base folder. I have removed and re-installed, no difference. If try to change the location of base folder, I get:

Unexpected error AttributeError: ‘None Type’ object has no attribute ‘choose_base_path’

I really, really, really wish this product was more stable. When it’s working, I absolutely love it. I can have a common set of working folder across all my linux and Windows machines. But when it’s not working,all of my workflow is borked.

Hi @dmaker,

Can you let me know if this happens when you select the folder during onboarding/setup?

When I removed it and re-installed, it never asked me for a home folder location. Then when I launched the program, it said no base folder and gave the error message I included in my original post.

I don’t know if this is relevant or not, but yesterday morning on this box (Ubuntu 18.04 LTS), I used the built in backup tool to backup my home folder (which also includes the Insync base folder). Then later that day, I noticed that Insync no longer showed a home folder, even though the folder is there, it’s just not syncing.

I uninstalled again just now, then rebooted and then launched Insync. Same thing. It never asks me setup anything and it will not let me change the base folder.

Not sure what I can do here. This is my primary linux box. I use it to generate ssl csr and keys, and testssl reports on web sites, etc, and I have all of these files go to a folder on my one drive for business. With Insync broken, that workflow no longer works.

No suggestions? Would be really nice to get this working again.

I tried uninstalling/reinstalling. Still the same. When I reinstall, it is aware of the previous install and will not let me change base folder and keeps giving that error.

Am I just SOL? No support?

Hi @dmaker,

Instead of uninstalling, could you try to remove the account and add it back again? That would give you the chance to pick the base folder after you add the account.

Let me know how that goes!

How do I remove an account? I can’t seem to find that option anywhere.

Ok, found where to remove account. This made no difference. When I went to add the account back, it says it is already being synced, and will not allow me to change the root folder and continues to give the same error.

I fixed it. This time I removed my account, uninstalled. Rebooted, and then installed again and was able to run setup as is from fresh install.