Ubuntu mate 18.04 insync not displaying tray icon after upgrade


#1

As above. Have tried sni-qt install (already installed) and back level insync and current level insync. All NG. Insync is running but tray icon and therefore gui not available. Was working on 17.10 before upgrade. Any help appreciated!


#2

Hi!

Below are the common causes for the tray icon not showing:

  • In some cases, when Insync is set to run at startup the tray icon is not shown. To confirm that Insync is running, run ps -ef | grep ‘insync start’; if there’s an output then Insync is running. In this case, try stopping then restarting Insync to see if the tray icon will show
  • Sometimes an outdated video card driver could cause the tray icon to not show. Try updating your video card driver if possible and restart Insync.
  • When using GNOME Shell, legacy tray icons are moved to the bottom left of the screen. They are not shown by default, which makes them hard to find. To show them on the upper right try the TopIcons extension: https://extensions.gnome.org/extension/495/topicons/ (note that in recent versions of GNOME, tray icons have been disabled entirely)

Let me know if the issue still persists after trying the steps above.


#3

Hi, Insync seems not to start.
I tried

~$ insync start --no-daemon
and the output was
Gtk-Message: 18:13:20.415: Failed to load module “canberra-gtk-module”

Then I tried

ps -ef | grep ‘insync start’
and the output was
grep: start’: File o directory non esistente

Please


#4

Hi @Andrea_de_Natale_Sif

Sorry for the inconvenience! What distro and version are you using? 32-bit or 64-bit?


#5

I too am having problems with Ubuntu 18.04LTS, running insync 1.4.8.37107

On my 64bit system, the tray Icon does not show but insync is running and it is syncing.

  • I do not have or need sni-qt, I am running a GTK system, Ubuntu Mate.
  • I have tried stopping and restarting.
  • I don’t use exotic video cards or video drivers.
    The legacy support for Tray Icons, down on lower left (fortunately) stopped after U17.
    However, I do know that the way TrayIcons are show has changed. The gnomes of Gnome seem to have waged a war on TrayIcons and are not interested in supporting what they consider an “old” model. Perhaps one of them was frightened by a SystemTrayIcon when young ?
    Ubuntu distros based on Gnome do however support the (now abandonded) Unity AppIndicator model.
    Does this all mean that insync is not going to be upgraded to what Gnome finds 'acceptable" ?

(I’ll lay on the floor and kick and scream …)


#6

What’s the negative of downloading sni-qt,rebooting, and seeing if it works?


#7

Ah, sorry, it turns out sni-qt is, in fact installed already. I really don’t know why, but its there ! And the icon does not show.

(the downside is it brings along a load of QT dependancies and, yep, they are there too!)

Davo


#8

Bleh that’s a good point.

I read online a bit ago that the tray icon would only load for this person if they ran insync as root.
Have you tried that?


#9

No, 20 years as a sys admin has taught me not to run user apps as root. So, I just tried it, it pops up a config screen, I really don’t want to config another system to poke at my Google Drive so I stopped there.

I really think we are looking a manifestation of -


an interesting is long read…

Davo


#10

And talking of interesting reads -

(note that in recent versions of GNOME, tray icons have been disabled entirely)

and, worryingly, that quote is from the Insync help pages :

are we getting to the stage where we have to choose between Gnome and Insync ? (I have not used KDE for a very long time …)


#11

18.04 LTS. I didn’t have a tray icon, and then after some futzing around which I have forgotten, I did. Now it’s gone again.

Here’s a suggestion for a quick work-around. If I try to start insync while it’s already running, I get the message “It seems another Insync app is already running. Will quit now.” If you could make the second instance bring up the app window of the first instance before quitting, I would be able to get my work done, if clunkily, while this problem is figured out.


#12

Thanks @Toolsmith, sad we have to resort to tricks like that !
I cannot try your suggestion right now, away from home where the particular install is. Fortunately, I did not update my laptop, 16.04 is fine.

Interesting, I also note that 18.04 works fine on a 32bit system. Only difference is it was a fresh install, where the troublesome 64bit was an upgrade. Not sure I’m willing to trash that install just to see if a fresh install works with Insync but …
Davo (hoping to hear an official Insync response soon)


#13

Hi! Sorry for not replying sooner.

Can you please try https://extensions.gnome.org/extension/615/appindicator-support/ instead? Also note that the TopIcons extension should be disabled. :slight_smile: Let me know if the issue still persists.


#14

I cannot test it for several weeks as I am away from that machine. I am sure the others following this thread can however.
But I’m not convinced its a great long term solution even if it works (and that seems about 50% of reviews). As a gnome extension, its messy to install and likely to become unsupported as has several predecessors.

Unless the gnome developers can be convinced otherwise, Insync needs to change the way it shows its system tray icon.


#15

I haven’t tried the gnome extension (and based on DB’s description am not anxious to) but do have some additional info: the icon on the topbar comes and goes! It will often be there after a reboot and then when I glance up later it’s gone.


#16

Thanks for the feedback, @David_Bannon and @Toolsmith! We’ll definitely look into this issue.


#17

Still unhappy with that gnome-shell extension (the install process mainly) I started poking around. And found that if you right click a sensitive spot (keep trying) around the panel where the icon should appear, you get a menu that includes “+Add to Panel” - lots of things available but if you add “Indicator Applet”, grey circle with an exclamation mark, suddenly the Insync indicator comes back again ! Along with some other old friends…

Mine was an upgrade rather than a fresh install, perhaps the upgrade forgets to turn the “Indicator Applet” back on. It appears to be a container for our much loved (but hated by gnome) app indicators !

Fantastic !

Davo


#18

Thanks for the update @David_Bannon! I’ll let our engineers know about this. :slight_smile:


#21

Hi David. I’ve also upgraded and had the same issue. Your workaround also worked for me; after installing this ‘indicator applet’ the insync icon came back. Thank you very much.


#22

Simple restart of the Gnome shell seems to correct this (running 18.04 and have insync starting at boot).

The icon is almost always missing from the menu bar, so doing a ALT+F2, then typing r in the command window box that opens up, then hitting the enter key solves it for me.

The above worked when ALL of prior suggested solutions had been attempted and failed for me.