Unexpected attribute error

When I try to sync a folder from my Google Drive to an external hard drive I get an error that reads: Unexpected error AttributeError: ‘NoneType’ object has no attribute 'new_op

Any help is appreciated. This worked a couple of weeks ago.

Hi @Mark_Letteney,

Any chance you’ve sent an email to support@insynchq.com? If not, please click the dropdown for that error message and choose “REPORT” so we can be notified! Do include your logs.db and out.txt files as well: https://help.insynchq.com/en/articles/1834816-locating-the-log-files

FWIW, I got the same error, on a PC. here’s what happened:

  • unsync a team drive
  • try to remove the unsynced local drive. be prevented from dooing that because some files are “in use”
  • since it’s still not possible after a dozen of seconds, shut down Insync, and then remove successfully the local drive
  • restart Insync. that’s when you get the message

Personally, I got rid of the notification (that appears whenever Insync is started) by first quitting Insync, recreating a folder with the exact same path as the one I previously removed (but empty this time), and restarting Insync. No error this time, and afterwards I could remove the folder once and for all.

1 Like

Thanks for walking me through the steps you took that got to this error as well as what you did to clear it. :slight_smile:

Do you mind sharing your logs.db and out.txt files? You can send that to support@insynchq.com with the link to this post :slight_smile:

1 Like

This error has resurfaced. I have emailed the log files to the support email address.

Attribute errors in Python are generally raised when you try to access or call an attribute that a particular object type doesn’t possess. It’s simply because there is no attribute with the name you called, for that Object. This means that you got the error when the “module” does not contain the method you are calling. But it is evident that the method is there, which leads to believe that may be the method was added by you in the source code after you had already imported the file (module). Or, some times packages get deprecated and they rename some functions. If that is true, then you may want to exit and reimport the module once again to be able to access the new method .

You can do it in another way to reimport the module with changes without having to exit the interpreter is to do the following:


If you are using python 3.2 or 3.3 you should:

import imp

If running Python 3.4 and up, do import importlib, then do:

import importlib

The importlib.reload() method reload a previously imported module. The argument must be a module object, so it must have been successfully imported before .

1 Like