Unexpected error modifycloudgdreg

I updated to v3.0.23… yesterday before updating to Catalina (from 1.57) and after some teething problems where lots of files were being re-synced that didn’t need to be synced and some duplication of files I am left with three errors.

two errors messages of:
unexpected error doing modifycloudgdreg: Insufficient permissions to perform this operation

…and one error where it says:
unexpected error doing modifycloudgdreg: the file does not support revisions

  1. Can someone help me find out more information (log files?), or how to solve this?

  2. It would be useful if insync errors could provide a link to the cloud and/or local file that is causing the error. I suspect that if armed with this information I could probably solve this by creating new versions of the problem files, delete the old files and clear this error.


We implemented a fix on this for 3.0.23, however, it looks like it’s still occurring on your end. Please send in the link to this post along with the logs.db and the out.txt file to support@insynchq.com?

For 2, yes this is ideal. We’ll try to incorporate this in future improvements to the “Attention Required” tab.

Thanks for the quick reply. I have sent these to your support mailbox.

1 Like

I have exactly the same issues. I am on Posted the log files to the support addres.

1 Like

I have the same problem too.

1 Like

Same issue. Windows 10, same version as jiho.

1 Like

Hi guys best to send the following information to support@insynchq.com to assist you since the modifycloudgdreg error is a generic error:

  1. Screenshot of your error
  2. logs.db + out.txt files (https://help.insynchq.com/en/articles/1834816-locating-the-log-files)
  3. Insync version

Thank you!

Hi all, especially InSync friends … is there any update on this bug? Your communication on it has been commendable, but is there any outlook on when we can expect a fix? It’s been a little while, and while it doesn’t really render InSynch unusable, having the big “error” icon in my menu bar is annoying and makes me check it frequently for fear of missing a “real” error. It’s definitely making me lose my enthusiasm about the product, so to speak … thanks for whatever you can share with us affected users.

1 Like

Are you experiencing the same modifycloudgdreg: Insufficient permissions to perform this operation bug? We attempted to fix this in 3.0.23, but unfortunately it is still recurring. Can you send in your logs to support@insynchq.com?

modifycloudreg errors are general and we will need a screenshot as well to confirm that this is either a new or old bug. Thank you!

I am experiencing this bug as well. I sent in my screenshot, logs.db + out.txt files to support@insynchq.com on the 22nd. I haven’t received any response.

1 Like

So sorry for that David, I have followed this up with my team. You should be getting a response now.

Anyone else still have this problem?

I am now on v3.025.40643

1 Like

Same problem and same version. Tried to wipe and reinstall to no avail.

1 Like

Hi @helgel and @Oliver_Jobson,

Could you please send your logs to support@insynchq.com with the link to this post? Please include your OS, Insync version, and a screenshot of the complete error message on the app.

Thank you!

I’m using Insync on Macos Catalina. I am receiving the exact same error as everyone else here. I sent a support e-mail with screenshots & logs. This has become a massive blocker for my workflow and I very much regret updating Insync :frowning:

Same issue here.
Please, fix it!