Warnings about not syncing symlinks

After insync updated today I now get a large number of “attention required” warnings, along with the red exclamation point on the tray icon. The warnings are about insync not being able to sync symlinks to google drive. So I have never seen these message before- maybe it has never synced symlinks before and now it is just notifying me as part of a new SW feature?

But the bottom line is that I don’t really want to see messages about symlinks. Can these be turned off? I only want to see error notices about real files not syncing or conflicts, as symlinks are not that critical. Conflicts happen quite often, and they will be buried in these nuisance symlink notices.

And lastly, aren’t symlinks supposed to work in inync anyway? I’ve never noticed it not syncing them before, and info on the web says insync supports them…


I too have this problem, but I’m on Windows. I get those Symlink-Messages all the time, from folders that do not exist at all (neither locally nor on google drive).

This is new since 3.2.3? and it is really annoying.

Symlink support on Insync 3 works via Local Selective Sync. Thank you @F_M and @bnpndxtr01 for bringing this up!

Could you please email your logs.db and out.txt files to support@insynchq.com with the link to this post? Those files can be found by clicking the 3 dots on the upper right > Help > Open logs.

We’ll look into this!

So this is where the terminology is getting confusing. So can we first establish if insync supports symlinks or not?

I think from the latest discussion Ive found that the answer is no- right? As I understand it, local sync is not the same thing as a symlink, but instead rather a way to add arbitrary folders to the group of synched folders without actually moving those folders to a subfolder inside the insync folder tree.

In my case local sync doesn’t make any sense because the targets of my original symlinks are already within the folders that get synced by insync to google drive. So both my symlinks themselves and their targets are already in the folders that get synced. With anything I have in my insync folders, I never use symlinks that point to something outside my normal insync folder tree. I understand that this is what I’d normally want to use local sync for, but again that is not my scenario.

I absolutely had to get rid of these annoying notifications so for now I had no choice but to remove all of my symlinks that currently exist in my normal insync folders.

Hi @bnpndxtr01,

We’ll look into this since other users have also voiced out their concern regarding this prompt. Could you let me know if you already sent your logs.db for investigation?

No, I didn’t bother with the logs since its now seems clear what is going on based on the discussions. I was poking around on the web site and even found in the release notes that a new prompt was added in cases were the user tries to use symlinks. So I think the redux here is just that insync doesn’t sync traditional symlinks (maybe this is a limitation with google drive or onedrive actually?) and now has just added a notice to let the user know that they are not being synced.

If you want my suggestion about a change moving forward it would be this. If insyc really doesn’t sync symlinks, then I think a prompt that is turned on by default is a good idea. But then it would be great to have a settings option checkbox to turn off the notices about just the symlink issue (but does NOT also turn off other important notices like local/cloud conflicts, etc). I think most users probably would like to know that symlinks won’t work, but then don’t want to be reminded of it after the first time they see it. Currently every time insyinc is restarted, you see all these notices again, and that gives the impression that something is perpetually broken. Adding a checkbox in the settings would be a nice way to make it the users choice to not be reminded, and having the messages turned on by default insures that the user sees the message at least once.

Local sync is a nice feature, but I don’t use it like a symlink. It is actually more of a could sync extension feature and I think it is a nice one btw.


This message is a big problem for me. I use insync on multiple Linux machines to keep my home directory on each of them synched to the same google drive folder. The directory contains lots of symlinks (about 1600 of them). Up until recently insync ignored the symlinks quietly. Now whenever I start insync it flags each symlink as “Attention required” with a message like

/home/arnold/Insync/gdrive/home/www/Moebius was not uploaded because syncing symlinks is not supported. Please use Local Selective Sync from the Cloud Browser and choose the target folder to be synced.

I get 1600 such message every time I start insync. If I have “Show pop-up notifications” checked in the preferences, I also get 1600 pop-up notifications!

Please fix this!

Concerning support for symlinks, I don’t know what Mia means when she says symlink support on Insync 3 works via Local Selective Sync. The symlink support I would like is when two computers sync the same google drive folder, if I create a symlink on one of the computers, the same symlink will appear on the other computer, just like if I create a file on one of the computers the same file will appear on the other. Is this possible?


@bnpndxtr01 You have a strong point with that suggestion; improving the prompt is indeed in our to-do list. :slight_smile:

@dnarnold, my apologies for the wrong choice of words-- I should have said that symlink support is not supported on Insync 3, and a workaround is to instead sync the target folder via Local Selective Sync. Thank you for pointing that out.

I have the same problem. Is there any fix perspective?

Linux is symlink based… There is a lot of them on my acccount

1 Like

We are working on this with our engineers to address the prompt. Were you trying to sync any symlinks at the time it popped up? If so, could you try to sync the target folder via Local Selective Sync instead?

Yes, all those warnings aren’t good at all… Perhaps I miss a really important warning among them.

For me it would be important to sync the symlink itself, and not the target file or directory.
Syncing the target folder is already addressed by the ‘local selective sync’.

Suppose a create a symlink and Insync creates a copy (not a link) of the target. In another computer I’ll have two copies of this file! If I edit one of them I’ll have a huge consistency problem! And how the original box will handle the mapping of two distinct files back to a file and a symlink?

I don’t really care how Google Drive will interpret the symlink in the web interface. I just like to have my Linux boxes synced accordingly.


Hi everyone!

I had the same problem with the update, will Insync don’t support these symlinks anymore or it will be solved in a future update?

Hi. I’m suffering the same issue since one of the updates. Any chance this will be fixed somehow? It’s really annoying to have those errors every time the application starts.

1 Like

Hi! You can disable these prompts by going to the three-dot menu on the upper right > Preferences > uncheck the third box :slight_smile:

This is not a solution. Disabeling all messages is not the same as disabeling only the symlinks messages

I totally agree with you jander. It would be great if we could just sync the symlink itself, without the folder to that link, since the folder can be synced otherwises.

Symlink files being different on windows and linux is not a big deal, if both types are synchronised, resulting in two link-files being shown in the folder, one for Windows and one for Linux, one working in one system and the other one in the other. The user can deal with this in his own way.

I’m not sure how long this setting has existed, but you are correct, there is a setting I can disable called “Show warning prompts about unsynced symlinks”. This seems to be the solution everyone on this thread wants with regard to notifications.

Regarding actually syncing symlinks, I agree it’d be useful and interesting. I’m not sure how it would work… Insync detects a local symlink and then creates a “fake” text file in Google drive with some special format that Insync would detect so it could create a local symlink on another computer in the same way as the first computer. Maybe it’s a JSON file at the root of the tree or possibly individual text files with a name like “symlink:link_name” and the content would be the file path that you’d get with the Linux readlink utility (print resolved symbolic links or canonical file names).

@dnarnold I’m trying to do something similar (but mainly for backup and restore purposes, not for a concurrent home drive across multiple machines). How is your Insync set up? Is your base folder the same as your home directory or do you just use the default location and then selective local sync your home/user folder? Upon initial setup, I selected the /home folder as my base folder and now it’s syncing everything, which I guess is what I wanted. But not sure what will happen to my home directory if I change my InSync base folder.