What can I do when Sym-linked folder does not upload?


#1

I want to backup my entire Pictures folder. I created a sym link with Insync’s Services, but no folder showed in my Insync folder. Then I used Terminal’s ln -s
command, and the folder showed up.
But it does not upload. Is there a way to force a folder to upload? Whether I leave it at root of my Insync folder, or move it into another folder, it does not upload, just sits there. Is there a way to force upload? The folder is checked to upload on your Manage Syncs page.


#2

Tagging our engineer @lpugoy and he will get back to you.


#3

@Silicon_Breath: When you created a sym link with Insync’s Services, was it similar to this: How to sync folders outside of the Insync folder?

Have you tried restarting Insync to check if that triggers the upload?

Also are there any entries in the Errors and Actions Required sections of the Insync app window?

Is there an entry in your Ignore list: How to use the ignore list?


#4

Thank you for your help.
Yes, I use Insync’s Service on a Mac. It won’t create a sym folder inside my Insync folder. Only when I use the Terminal’s ln -s command line.

Due to my relatively slow connection I start Insync when I do not need the bandwidth. The folder has not started to upload in days.

I can not even find this file either. How do I get rid of this error message?

Concerning the ignore list. In my Insync folder I have one folder for this machine. When I sym-linked the trouble folder it ended up at root of the Insync folder. I moved it in Finder to the main upload folder so that Insync could notice that it was added at the right place.


#5

@Silicon_Breath: I see. Please send your logs to support@insynchq.com for investigation: How to find the log files.

Regarding the error message, the file “1505 Shoreline Dr SB CA 93109.gdmap” is a gdlink file. It is not a normal file, rather it only contains a link to the “Google My Maps” document in your Google Drive. However it looks like the document it links to does not exist anymore, so it can be deleted to remove the error message. If you can’t find it in your Insync folder please send a copy of the folder ~/.config/Insync/dbs while Insync is stopped so we can check for you. You can compress it before sending to save space.


#6

SOLVED. I found a way to upload the Pictures folder. First I went to GDrive and created a folder named ‚Pictures.‘ After it synched to my Insync folder on my Mac, I symlinked folders from the original Pictures folder one at a time, and Insync promptly started to sync them.
Thank you for all of your help.