Www.google-analytics.com CERTIFICATE_VERIFY_FAILED


#1

Update: Maybe this is a Google requirement, which seems odd. Trust google to force info out of us.

Original Post:
Why does InSync need to connect with www.google-analytics.com from the linux client.
What value could this possibly provide what benefit is it to the Customer, versus benefit to InSync.
If this is a banned domain InSync seems to not work (not yet proven 100%).

All I know is I get this error in the Log.db
{“message”: “SSL certificate validation failed! (host: %s, error: %r)”, “params”: [“www.google-analytics.com”, “SSLError(1, u’[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)’)”]}
And I have unsyncd folders, which I am yet to explain why the folders are missing, this still could be a different fault.

Which seems unnecessary.

Please explain!


Insync Headless Offline
#2

Hi @Jamie_Browning,

We use Google Analytics for app telemetry. This is anonymized and can be disabled through your app’s Preferences.

An SSL error usually means that there might be an issue in your network setup (eg. network proxy.)

With that in mind, could you let me know if your network is behind a proxy? Also is your system time correct?

Edit: I just wanted to let you know that there is no way to switch off analytics on Headless :slightly_frowning_face:


#3

My Ubuntu machine has Google Analytics Blocked in the Hosts File, I have now had to open it up. But it seems strange that GAnalytics is required for insync
Just plain annoying!


#4

Hi Jamie,

Our use of analytics is anonymized.

We send anonymized data to Google Analytics, that is, we can’t pinpoint exactly who the user is that sent a particular data. We send relevant events to Google Analytics (e.g. when the app has started or ended, when the app is being used) together with the following:

App version
Platform info
Quota info of the account (total, used, others, trashed)

#5

I’m not having any issue but I figured I’d still give my input on this.

I’m running Insync headless on Ubuntu Server 18.04, one of the things I’m running on that server apart from Insync is Pi-hole. The other day I saw that I was getting a ton of blocked requests from localhost to google analytics. The interval between requests is anywhere from 3 to 20 seconds apart. My question would be why is it spamming my Pi-hole with requests so often, couildn’t it just try and make contact in shorter intervals.

Also is there any way to disable telemetry data being sent from insync-headless?