“Your locale is not set to UTF-8. This will raise errors with non-ASCII filenames.”

“Your locale is not set to UTF-8. This will raise errors with non-ASCII filenames.” (Linux; actions required)

Happens on Linux.

See: (LINUX) What does "Your locale is not set to UTF-8" mean?

i get this message on opensuse leap 42.2 but when i run the locale command, it gives:
root@sushimonster:/home/mattie/localrepo# locale
LANG=en_BE.UTF-8
LC_CTYPE=“en_BE.UTF-8”
LC_NUMERIC=“en_BE.UTF-8”
LC_TIME=“en_BE.UTF-8”
LC_COLLATE=“en_BE.UTF-8”
LC_MONETARY=“en_BE.UTF-8”
LC_MESSAGES=“en_BE.UTF-8”
LC_PAPER=“en_BE.UTF-8”
LC_NAME=“en_BE.UTF-8”
LC_ADDRESS=“en_BE.UTF-8”
LC_TELEPHONE=“en_BE.UTF-8”
LC_MEASUREMENT=“en_BE.UTF-8”
LC_IDENTIFICATION=“en_BE.UTF-8”
LC_ALL=

seems fine to me?

tagging our engineer @lpugoy

@mxttie: Please run the locale command as the user Insync is running as. Or if you are running Insync as root, please run this as well: /usr/lib/insync/py -c 'import sys; print sys.getfilesystemencoding()'. It should output UTF-8.

I’m having the same issue as @mxttie - running arch with openbox
locale (same user as insync)
LANG=en_CA.UTF-8
LC_CTYPE=“en_CA.UTF-8”
LC_NUMERIC=“en_CA.UTF-8”
LC_TIME=“en_CA.UTF-8”
LC_COLLATE=“en_CA.UTF-8”
LC_MONETARY=“en_CA.UTF-8”
LC_MESSAGES=“en_CA.UTF-8”
LC_PAPER=“en_CA.UTF-8”
LC_NAME=“en_CA.UTF-8”
LC_ADDRESS=“en_CA.UTF-8”
LC_TELEPHONE=“en_CA.UTF-8”
LC_MEASUREMENT=“en_CA.UTF-8”
LC_IDENTIFICATION=“en_CA.UTF-8”
LC_ALL=en_CA.UTF-8

/usr/lib/insync/py -c ‘import sys; print sys.getfilesystemencoding()’
UTF-8

@Aedyn: Apologies for not replying sooner. How is Insync being called in your system? Are you just running it from /usr/bin/insync?

I have the start command “insync start” as part of my systems autostart.

@Aedyn: I see. Is the warning still raised when you stop and start Insync manually? Also please try adding a call to locale inside /usr/bin/insync to check if the locale settings were somehow changed.

Hi @lpugoy

I don’t know when it happened, but the problem got resolved by itself! I no longer get this warning My current insync version is 1.3.16.36155

Btw, the locale output under the same user as insync is the same (don’t remember why i put the output run under root…)

cheers

According to this Insync forum answer, Insync uses the LC_ALL variable for checking the locale.

However, according to the Arch wiki the LC_ALL variable should not be used, except for testing and debugging, see:

https://wiki.archlinux.org/index.php/locale#LC_ALL:_troubleshooting

Is this a mistake? Shouldn’t Insync use another variable than LC_ALL?

@lpugoy, can you look at this?

@Arthur_Borsboom: Thanks for bringing this up. From my test it looks like setting the LC_CTYPE variable should be sufficient. I have updated the forums post.

@lpugoy I am still getting this error. Insync is running as user, locales seem to be correct:

my locale: LANG=en_US.UTF-8
LC_CTYPE=“en_US.UTF-8”
LC_NUMERIC=“en_US.UTF-8”
LC_TIME=en_DE.UTF-8
LC_COLLATE=“en_US.UTF-8”
LC_MONETARY=“en_US.UTF-8”
LC_MESSAGES=“en_US.UTF-8”
LC_PAPER=“en_US.UTF-8”
LC_NAME=“en_US.UTF-8”
LC_ADDRESS=“en_US.UTF-8”
LC_TELEPHONE=“en_US.UTF-8”
LC_MEASUREMENT=“en_US.UTF-8”
LC_IDENTIFICATION=“en_US.UTF-8”
LC_ALL=

output from commandline:
teja@neroII:~/> /usr/lib/insync/py -c ‘import sys; print sys.getfilesystemencoding()’
UTF-8

opensuse tumbleweed, insync --version 1.3.14.36131

When I run that code the output is: ANSI_X3.4-1968

I updated to 1.5.4 and just I have seen this error.
openSUSE Tumbleweed x86_64

Hi @Nestor_Acevedo

Per our engineer, you need to set your locale to UTF-8. :slight_smile: Let me know if the error persists after enabling the setting. Thanks!

I had a similar issue. I use Manjaro Linux KDE 18.0.4
The problem is not with insync.
My output from what Ipugoy gave was also UTF-8, however, I still had the error on insync and my linux system.
After trying everything under the sun this worked for me:
I removed BOTH of these files and after a reboot everything worked!!
~/.config/plasma-localerc
~/.config/plasma-locale-settings.sh

The plasma settings were overriding all other settings.
You need to view hidden files/folders to see these: located in the HOME folder.
Best wishes

2 Likes