Another indicator applet problem


#1

Can anyone explain what would cause this issue… Running Mint 18 XFCE

When I first install, it seems everything installs just fine and the app starts and the indicator looks “normal”. If I shut the app off for any reason (restart, just close the app, etc) when I restart it, the above is the icon I get. The app appears to otherwise work normally. Here’s the pastebin of my log… I’m assuming this dconf-critical error permission might have something to do with it.

http://pastebin.com/jP866UeF

Edit: After looking a little further, it seems I have the same problem as this thread… I also found if I start insync as root, the icon is normal.

Obviously, I don’t want to be running this app as root, but maybe it will help nail down the permission error w/ dconf that is causing this issue.


Ubuntu Mate tray icon
#2

I also believe the issue is a duplicate of what I posted. Might be good to merge them if possible to avoid duplicates. As you stated, I prefer not to run with root privs as well, for many reasons. Until resolved, I am not running the application, I am using Grive w/GUI.


#3

Tagging our engineer @lpugoy and he will get back to you guys.


#4

@Ken_M: Please try these steps as a workaround:

sudo apt-get install imagemagick
temp=$(mktemp -d)
pushd "$temp"
mkdir 24x24
cp /usr/share/icons/hicolor/48x48/status/insync-* .
for status in $(ls *.png); do
  convert "$status" -resize 24x24 24x24/"$status"
done
sudo cp 24x24/* /usr/share/icons/hicolor/24x24/status/
sudo gtk-update-icon-cache /usr/share/icons/hicolor
popd
rm -r "$temp"

This creates smaller versions of the tray icons.


#5

That seems to have done the trick… thanks.


#6

@lpugoy - for my portion of this issue, this resolution does not completely correct the issue. There is still too much space being taken up in the tray. Example, using _ as a space, here is a layout of tray.
app__app__app____insync____app__app__app
Additionally, even with the creation of newly resized icons, they are still cut off a bit.
I do understand that this seems picky, but as I am sure you know, having and leaving glitches of any sort in the tray or panel easily leads to malfunctions. My concern is simply that the placement of InSync on the tray is different than all others there, using the logic that all others act and appear in the same manner, and InSync is the one left different. While I am sure the code for operation is just fine and this is purely cosmetic, I have just had too many experiences of such bugs and glitches messing up the tray and or panels. Hope you can understand my concern.


#7

I dunno, maybe it’s a difference in Mate and XFCE, but it seems to be the perfect solution for me…


#8

I agree with your statement. I have seen a few Gnome pieces not function as desired on MATE for example. I can usually get such things to work, sometimes just as simple as adding “MATE” to a string in a file so it calls the proper files… and other times it is having to do a specific launch, for example “XDG_CURRENT_DESKTOP=GNOME gnome-control-center” which allows me to run the Gnome control center in MATE without any issues. I just need to tell it I am using Gnome so it will run.


#9

Unfortunately doesn’t work for me in Mint 18.1, Cinnamon 3.2.7: when I increase the size of the panel, the icon is way too big and partially squashes the position of the other icons. If the panel has the default size then the icon is too small. :frowning:

with Insync:

without:


#10

@fsoldera: Apologies for the trouble. Please try the workaround here: Another indicator applet problem.


#11

Thanks @lpugoy, I already tried the workaround without success. Also notice in the screenshot that “Shutter”'s icon has the opposite problem, it doesn’t scale up.

Do you have any other suggestion?


#12

@fsoldera: I see. I can’t replicate the issue unfortunately. Are you using the package for Ubuntu 16.04 from www.insynchq.com/downloads? Did you change the panel size using these steps: http://winaero.com/blog/make-panel-and-app-icons-bigger-in-cinnamon/?


#13
  1. Yes, I increased the size of the panel using the described steps
  2. Insync for Ubuntu 16.04 64-bit (Mint LMDE is based on that Ubuntu version). But I tried also the Debian version, which is compatible with Mint, same result.

#14

@lpugoy I have now installed Mint 18.1 (Serena). After the download of Insync for Ubuntu 16.04 everything works fine now.

Thanks anyway for you attention :slight_smile:


#15

Thank you @lpugoy, your workaround worked perfectly, also from embles in Caja (file browser) where I was the same problem in Ubuntu MATE 17.10, executing the same conversion for folder /usr/share/caja/icons/hicolor/64x64/embles, and putting in /usr/share/caja/icons/hicolor/24x24/embles.


#16

Thank you @lpugoy! The workaround reduced my icon size in Ubuntu MATE 18.10.


#17

Thanks, it worked on Xubuntu 18.10